Jump to content
Corsair Community

X128 No longer found in BIOS


Recommended Posts

Hi All,


My first post and need some help.


I have a Dell Vostro V13 with a x128 drive installed. It has been running GREAT!


Approx 2 months ago my PC could not boot into BIOS. The PC is provided by work and a Dell technician was called out. Approx a week after the failure, the Dell tech arrived and the PC booted fine.


Then yesterday same issue. First, I tried swapping RAM, then removed the SSD and BIOS booted fine. Installing another drive and it works fine. Installing the SSD in another PC.. no luck does not get detected. In addition I have tried the following... installing SSD drive into a USB caddy, changing ATA and AHCI settings in BIOS on multiple PC's. Nothing has helped.


I really need the data from the SSD drive and I'm starting to get worried. What I think is strange is that when this first occurred 2 months ago (I had not narrowed it down to a disk failure) it fixed itself after a week.


Is there something I can do this time around?? Any ideas? I'm reading this seems to be a common issue with the X-series.


Also, if this is terminal, what would my data recovery options be??


Thanks for your help guys./.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...