Jump to content
Corsair Community

problem with F120


Recommended Posts

I have spent 7 hours following all of the suggestions to no avail. BIOS sees the drive but Windows 7 installer keeps asking for a driver.


I am completely beside myself.


Any other suggestions that aren't currently floating around the internet? I have tried it all.


Can anyone recommend a better drive than the F120?

Link to comment
Share on other sites

Hey guys. I updated my specs.


I have tried:




Installing the OS on another machine

Restoring an image on the drive


Just about every tip or trick suggested on the Internet I have tried.


It does not show up on my machine as an available device to select for install. No matter what I select RAID/IDE/AHCI, it asks for a driver to proceed. I give it the AHCI/RAID driver that I normally use and it doesn't find anything. It does show up in the BIOS. However, Windows 7 installer can not see it. My laptop picks the drive right up and I can install Windows 7 that way. The firmware on the drive is 2.0.


I'm up to about 12 hours now fighting with this thing. I have even tried the weird voodoo people suggested to no avail.



Link to comment
Share on other sites

I wanted to thank everyone for their suggestions.


I did do a Secure Erase on it twice. I even waited 6+ hours to ensure it was finished. I tried the 100MG partition to no avail.


I returned the Corsair drive and bought another drive. The new drive works like a charm!


Thanks again for the help and suggestions!

Link to comment
Share on other sites

  • 1 year later...

I just had my second F120 SSD drive die.


I used the search feature and there seems to be quite a few problems with the model.


Why am I only getting 6-12 months of life out of each drive?


They work great for a few months, then I start getting lock-ups followed by BSOD. Eventually, it is not found by the BIOS, and recovery of data is moot as most of it is missing when I am able to mount it through USB. I finally go it to mount tonight and the windows directory was completely empty.


I cannot reformat it or reinstall Windows or backups.


I sent in for an RMA, again.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...