Jump to content
Corsair Community

Drive not found at boot


Recommended Posts

This might be related to a problem with the F240 drive I have. It is intermittent so I'm just waiting to see it again.


When I boot the machine I sometimes get the error:


Media test failure, check cable, no bootable device - insert boot disk and

press any key.


Nothing seems to fix it except unplugging the drive from the SATA cable. I thought I had a problem with the cable coming loose. I checked that. I even taped the cable in place. Still had the problem. Intermittent.


A number of solutions to try. One was make sure the drive cable is secure. I think it is. The second was related to the idea that the drive wasn't responding or wasn't responding quick enough. The only way to address that was upgrading the firmware from 1.1 to 2.0. I did that. No problems. The third, in researching that error message, it may be related to boot order. Maybe. I'll make sure the HD is first in the list.


Otherwise, no problems. No problems with sleep. It's a waiting game.


I'm using the Microsoft driver 6.1.7600.16385


So, until I'm sure this problem is fixed I have to carry around a #000 philips screwdriver.



I checked the boot order and the HD/SSD option isn't there at all. Only the CD and LAN options are visible. That is different. That was not the case with the hard drive install. I also note that the Corsair SSD isn't seen in the BIOS. The CD is visible. I remember that with the 1.1 version of the firmware the drive would show up. At least when I noticed. I didn't check every time. I believe that the check cable error message is for the PXE boot (LAN) and not related to the drive's cable. I've had to unplug the drive to get it to be recognized.



Checked again and the Corsair drive was present in the boot order BIOS options and recognized by the BIOS.

Comes and goes....

Link to comment
Share on other sites

I am running the latest BIOS available from Toshiba for the R705-P35. As many vendors do, this BIOS doesn't expose all the available options. I cannot increase the IDE timeout.


So far, I've had no problems. I've had the machine, shutdown, cold start, reboots, sleeps, hibernates, etc... No problems with the drive not being recognized.


Just a waiting game....


Thanks for the advice.


P.S. There was a recent update of the BIOS. The list of changes don't list anything specific about disks or SSDs.

Every time I restarted the machine, the SSD was identified by the BIOS. That's a good sign.

Link to comment
Share on other sites

  • 2 weeks later...

I got one "drive not found problem" on a cold boot. I rebooted and everything was fine. I did find that Intel released a new IDE ATA/ATAPI driver on December 15. So, I installed it.


I was running:


Intel 5 Series 4 port SATA AHCI controller



I upgraded to:


Intel 5 Series 4 port SATA AHCI controller



The new driver has been out in the wild for some time but I hadn't seen it on an American Intel site until recently.


Waiting to see how this one works out.


My machine:

Windows 7 Home Premium 64-bit

Corsair F240

Toshiba R705-P35


I found the driver at:


Intel SATA AHCI Driver

Link to comment
Share on other sites

Well, it happened again. The drive was not found at cold boot. I just powered off and booted again. The drive is found. It's a work around. At least I don't feel the need to carry around a screwdriver! I'm a little disappointed. From my reading of various blogs and forums it appears to be happening with Sandforce controllers.


What's the current thinking about this problem? Is it as suggested in this forum the ATA driver not shutting down the drive correctly? Is it a compatibility problem between the BIOS and the drive? Is it something that can reasonably be expected to be fixed with an SSD firmware update?

Link to comment
Share on other sites

The problem I have is not frequent. It's mostly an inconvience. I don't know if the laptop vendor knows there's a problem or if the manufacturer of the motherboard that the vendor uses knows if there is a problem or even if the support of an SSD is important to them.


For me, I can continue on with what I have. If the SSD didn't work in this system I'd have no need for it.


If you're lucky and the SSD works or the problems are just an inconvience then you're ok. It just seems to me like most/some/a tiny fraction (I don't know) systems aren't ready for Sandforce SSD drives. From what I've gathered in these forums the Corsair Force series with the 2.0 firmware is ready but that the motherboards are not yet compatible. You have a better chance with a very recent motherboard.


I don't know when another BIOS update will be available for my system. I'll just have to wait.

Link to comment
Share on other sites

I am using a Toshiba R700 laptop + F180(Corsair Force CSSD-F180GB2-BRKT) with the shipped firmware 2.0, both new, having the exact issue as you.


I believe it is the issue as those many are having at http://forum.corsair.com/forums/showthread.php?t=88053


I think I have to post the review warning about this situation on NewEgg, as this is a new product listed there.


For Corsair:


I have tried all other SSDs with my R700, they do not have this problem except the F180, so it is no more true that the test is not "recreatable", if you really care for you products you should test the drive with the forementioned machines or the machines with similar chipsets/specs/

Link to comment
Share on other sites

  • 2 weeks later...

I have the same issue with a toshiba r700 with the latest firmware (1.80) and a F120 also with the latest firmware (2.0).


The problem occurs only in cold boot, never after resuming from a suspend to ram.


Also tried other SSDs that work OK. The issue is only with the Corsair one. There is no issue if the SSD is connected through a e-sata dock.


This kind of issue is reported many times in the forum, and not only with the force series. Sadly, I don't think that this is an issue that can be corrected through a firmware update.


I think this is because of bad hardware that is just too close to the limits of the SATA specs timings.


Too bad to see that on a "premium" product.


I don't think I will ever buy a Corsair SSD again or recommend one.

Link to comment
Share on other sites

I'm also having detection problems. I recently tried to install an extreme series x128 ssd in my system but bios wouldn't detect the ssd at all. When I try to load bios with the SSD plugged in, it causes long delays and hang in loading. When it finally loads, bios doesn't recognize the ssd. Is there a fix for this? I had another corsair x128 installed on my system that ran just fine until it crashed. I applied for an RMA and got a refurb. The refurb won't boot out of the box and I can't format it because its not recognized. I'm starting to thing the RMA came dead on arrival. Thanks.
Link to comment
Share on other sites

  • Corsair Employees


Please use the link on the left and request an RMA and we will be happy to replace it.



Normally OEM's will do their own Validation testing I would suggest contacting the system manufacturer and asking if they have qualified any SSD drive on that system.


iamtoto, bangmal, rhesuspieces,

We are looking into these reports and at this time we believe that the issue stems from the reference bios for the chipset, as some of the major MB manufacturers have released BIOS updates for Sandforce compatibility issues.

However we are working with Sandforce and the top manufactures to try and work out a solution. But I suspect this may take some time to resolve. So the only option would be to wait for the next BIOS release and or the next firmware release on our drive and I am sorry I do not have an ETA when that might at this time. Or use another HDD in the system for the time being and then use this drive in a more compatible system.

Link to comment
Share on other sites

Can you please explain why I do NOT have any detection problem any more using the SAMES Toshiba laptops and a DIFFERENT BRAND Sandforce based SSD ?


By forum rules, I can't write that another 3 letters manufacturer sells Sandforce based SSD that WORKS.


It's a SHAME !

For years, I highly recommanded Corsair Products, because of their QUALITY.

While I'm still hoping that Corsair branded RAM are top quality, i can only say that:

- you destroyed my faith in corsair PSU by changing the great design of the CX400 and starting selling the CX430.

- you destroyed my faith in corsair SSD: If you can't have a strong partnership with Sandforce, then DON'T DESTROY YOUR BRAND NAME by supplying SSD that are not WORKING.


It's a pity, for an old Tech like me, to have to say that OCZ , worldwide known for their PURE Bull**** RAM & PowerSupplies, is able to ship SSD that works while CORSAIR isn't !


Just my two cents.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...