Jump to content
Corsair Community

BSOD/GSOD on resume from sleep RAID 0 and Asus Rampage III Formula


Recommended Posts

I am running two Corsair 60 GB SSDs in RAID 0 and when I resume from sleep with one exception when it did resume I always get a BSOD and lately GSOD (green) when resumng from sleep. The OS is Windows 7 Ultimate 64 bit.




The MB Bios is flashed to the latest AMI 0505 and I have 6 GB (2X3GB) of Corsair XMS3 CMX6GX3M3A1600C9 memory which is not listed on the ASUS QVL (Qualified Vendors List) for my MB.


Crystaldisk Infor 3.9.3 tells me the following about my RAID0 (C:) Boot drive.


The C: disk(s) show up as MARVELL RAID VD 0 119.16B

Firmware MV.R00-0 Serial No. 55627270c88a0000 Buffer size 8192 KB


Thanks in advance for your help.

Link to comment
Share on other sites

As per the Crystaldisk info I posted previously is the current firmware known?

Want to make sure there is new firmmware that hopefully fixes this.


And will have to figure out how to update the firmware.


BTW the information about the drive I got from the info on the store bill.

Link to comment
Share on other sites

  • 3 weeks later...

I have upgraded the firmware on my F60s to 2.0 and still get the BSODs with stop code F4 only on resume from sleep with two F60s in Raid 0.


The original firmware was 1.1 and will not show the firmware version when in Raid.


I have also tried different memory which is on the QVL and another video card with an Nvidia chipset and still the same problem. Also, reapplied MS Hotfix KB977178 and confirmed that Fix306215 is already installed.


My Raid 0 is on the Marvell controller, http://forums.legitreviews.com/about8066.html

Link to comment
Share on other sites

My friend has two O_C_Z 60GB SSDs in Raid 0 that run without any issues, including sleep.


When he has time we will try his drives and one if necessary. The problem might be the Marvell Controller. Looking at their website they want a model number to see available downloads.


I have backups of the Raid 0 system disks and tried to configure Raid 0 using Intel controller but Acronis bootable disk does not see the SATA drive that has the .tib Acronis backup. Conversely a Ghost backup did not see the Raid disks as best as I remember.


We worked on this till 2 AM and it was a work day, will schedule as my friends time permits.


The boot messages for the Marvell are:


Marvelll 88SE91xx Adapter - Bios Version

Mode: Cpu AHCI

Virutal disk Raid 0 Funcional Stripe 32K

Physical Dis

ID 0 - SATA Corsair 60 GB 3GB/S

ID 8 - SATA Corsair 60 GB 3GB/S


I wonder if there is some sort of update somewhere for Marvell?

Would like to be able to backup and restore my system if possible.

Link to comment
Share on other sites

  • Corsair Employee
You will need to break the RAID and run crystal Disk Info and see what firmware version is installed and if its not 2.0 I would suggest trying that I would also suggest using the Intel controller as well.
Link to comment
Share on other sites

Thanks Ram Guy!


Initially, when problem first surfaced I ensured as best as possible to update drivers. I used the Asus site relating to my Asus Rampage III Formula motherboard.


Further, I went into Device Manager on looked for an update there only to be notified that everything I checked is updated to the current version.


My Device Manager for Storage Controllers showed:


JMicron JMB36X Controller driver date 10/29/2009 and driver ver.

MARVELL 91xx 6G Controller driver date 12/25/2009 and driver ver.


Found a Marvell website that stated use Google to find the latest applicable driver version, I downloaded and installed the following:




Computer was rebooted and the first resume from sleep was OK???


A subsequent resume gave the same BSOD Stop Code F4 and the first parameter 0...03 as usual. Restarted the system and after another resume from sleep got STOP: C000021A {Fatal System Error} 0XC0000006 The System has been shutdown.


The recovery reboot gave me the following message:


Continue with system resume "or"

Delete restoration data and proceed to system boot menu.


It would only proceed with the restart if the latter option selected otherwise it would ask again.


So now under Device Manager the settings for the Marvell controller are:


Driver version

Driver date 5/7/2010


I have found a Marvell version here:



This doesn't relate to my motherboard, don't know what to do next.


Thanks very much.

Link to comment
Share on other sites

Ram Guy, do you think that trying the latest Marvell controller driver I manage to find (as per previous post) might cause problems so not worth trying?


It definitely seems like the Marvell Raid 0 has issues and is likely the cause of the resume from sleep BSODs, do you agree?


Will definitely try the Intel controller instead as you suggest.


Can we exclude the need for manually setting the memory timings in the BIOS as shown by CPUZ?

Link to comment
Share on other sites

  • Corsair Employee
I have not used the marvel controller because the Intel controller is 30-60% faster on every mother Board I have tried. But anything is possible please try the Intel controller and I would disable the Marvel controller to test the issue.
Link to comment
Share on other sites

Can anyone confirm if firmware 2.0 fixes the resume from sleep BSOD?

I would be very grateful.


Yes the 2.0 firmware fixes the sleep/BSOD problem. If you're still getting BSOD, it is quite possible that it is from the Marvell controller.


RAM GUY is right and the Intel controller is usually faster than Marvell. Even with SATA II drives if you run it on an Intel SATA II controller it is faster than a Marvell SATA III controller.

Link to comment
Share on other sites

  • 1 month later...

I am still on the Marvell controller, hope friend will have time in the next few weeks.


I upgraded to the latest MS service release and

now I am getting INTERNAL-POWER-ERROR with stop code A0 on attempt to enter sleep mode.


Have only been able to find a solution via google to increase the hibernate system file, which I did to no avail and I do know that Sleep is different and does not use the hibernate file.


What to do now?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...