Jump to content
Corsair Community

Brand new F160GBP2 won't hold data past a cold boot


Recommended Posts

Hi everyone,


I recently bought a new PC with two of these little wonders in it. Unfortunately, one seems to be having issues.


Neither BIOS nor Windows seems to have issues detecting the drive, but every time I turn off my PC and leave it for a while the second drive loses all it's data and Windows tells me the drive is not initialized. When I was first trying to setup the PC, I was going to put the two drives in a RAID0 configuration, but this second drive kept dropping itself out of the VD, so I gave up on that at the time and put it down to bad Windows drivers causing issues.


So far I've switched to ACHI, turned on TRIM, flashed the BIOS to the latest version I can find, and attempted to update the firmware on the drive itself, but the update tool couldn't recognize either of my disks, even though CrystalDiskInfo says my drives are on v1.1 at the moment.


The two parts I find weird about this whole thing is that one disk works perfectly, and the other does too, right up until I turn the box off. I've verified that it is not a power issue by disconnecting one of the video cards, which should free up more than enough power for the drive.


I'm stumped, did I just get a broken drive?

Link to comment
Share on other sites

I was just looking over the sysinfo32 stuff, and just noticed something a little odd:


Non-working drive:


Sectors/Track 63

Size 167.68 GB (180,043,153,920 bytes)

Total Cylinders 21,889

Total Sectors 351,646,785

Total Tracks 5,581,695

Tracks/Cylinder 255


Working drive:


Sectors/Track 19

Size 167.68 GB (180,043,644,928 bytes)

Total Cylinders 82,624

Total Sectors 351,647,744

Total Tracks 18,507,776

Tracks/Cylinder 224


They are reporting different physical layouts, could this be part of the problem?

Link to comment
Share on other sites

I tried to plug the discs into each of the three SATA controllers on my board, and still no luck getting the update application to recognize the drives.


You have to right click the update program and Run as administrator, despite if your account is administrative or not, this is simply how Windows 7 functions and you need to do this for the drives to be recognized.


IF that still doesn't work, you have to secure erase and format the drives before you update them, as sometimes if you have partitions on the drives then they will not be recognized. You can also try using a Live CD environment such as Hiren's or UBCD4Win because if the OS is running off of the drive that you are trying to update sometimes that can cause problems.

Link to comment
Share on other sites



Yes, I used the secure erase in Parted Magic, then used gparted in the same to initialise the partition table but not create the actual partitions. Cold booted after that, no partition table. Tried recreating it and adding partitions, still no luck




Ah, of course, I should have thought of running as administrator, my bad. Too long running XP. Both disks were recognised, the main system disc bluescreened while updating, but the other updated fine. The problem now though is that my PC won't see the disc at all now (bricked?)


At this point, I'm going to log an RA with the people I bought it with and see if I can get it replaced, unless someone can come up with something else? I've already tried disconnecting power, no luck.

Link to comment
Share on other sites

  • Corsair Employees
Just sue parted Magic to secure erase them and with Windows 7 there is not need to do anything prior to formatting them Windows 7 will align the partition properly with SSD's. I would try and get them to detect and then secure erase them again and you may have to change the IDE controller to IDE mode or AHCI.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...