Jump to content
Corsair Community

Help with F80 and Asus Striker Extreme


Recommended Posts

long story short.


i bought 2 F80 today, but i couldnt get the bios to recognize the drive.


my bios version is 1305


strange things are,


some time the bios recognize the drives, but after a restart, it wouldnt recognize any more.


i have tried single drive, different ports, different cables


occationally, it shows the drives, but after a restart, the drives are gone.


i have loaded bios default many times too.


please help. im very very frustrated.



BTW, the cables and F80s are tested on a intel 946gzis, both drives are recognized by windows 7

thanks in advance.





bios was flashed to the lastest 2002. still wont recognize the drives.


sometimes, both drives show up after a cold start. right after "detecting IDE drive", they will keep showing up like this if i just hit ctrl+alt+del to restart.


if i shut down the computer then start it again, it will hang on "detecting IDE drive" for 10 seconds then show no drive. if i hit ctrl+alt+del to restart, there would be no hanging, it will show "none" immediately.


this is really killing me. i get different result just by restarting.

Link to comment
Share on other sites

another topic.


now i kind believe the mobo is dead. i have had enough with ASUS. their products are only good when they are working.


now im facing a tough decision. to replace a mobo or build a new PC.


i really dont want to build a new PC before diablo3 comes out so please help me to choose a new mobo which will work with my existing hardwares.


Intel Core 2 Extreme X6800 2.93GHz, socket 775

2 strips of Corsair TWIN2X4096-6400C4DHX, total 4GB

Sound Blaster X-Fi

Geforce 8800 GTX 756MB

2 Corsair F80 SSD (just bought them)

2 Western Digital Raptor X


i bought those in 2006. it has been 4 years, but still run WoW very well.


please make some suggestions


Link to comment
Share on other sites

2 suggestions, check the BIOS battery and or replace it. the other is see if there is anything funky with the lcd poster readout on the back. thats usually a clue when strykers are dying.

also try with and without the blue lights around the board.

mine only boots with them off. :(

Link to comment
Share on other sites

those "xxxxinit" issues are all over the net, its a common striker problem usually solved by overclocking in some cases.


the board should work equally as well with or without the poster lights, if yours will not start with the lights off there is another major problem.

i just dont want to blame the SSD when im pretty convinced the board is doodoo.

well you have my .02 and i wish you luck getting a rig up soon with the new drive.

Link to comment
Share on other sites

  • Corsair Employees
I would check with the MB maker to be sure but I suspect it is not completing the first part of the post test's and does not have a code to display IE something wrong with the MB or the ASIC on the MB. Or it is not loading/Initializing the BIOS.
Link to comment
Share on other sites

Nothing wrong with the SSD, now this mobo doesn't even recognize my western digital raptor. I'm done with asus. And this mobo is a rma already, which doesn't even have a serial number


how about a gigabyte ga-x48-dq6? It seems it will work with the stuff I have and I can get it for 75 bucks off craigslist brand new


Thanks guys

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...