Jump to content
Corsair Community

Dell Poweredge T110 and TW3X4G1333C9A


Recommended Posts

I just purchased a 4GB kit of TW3X4G1333C9A and the machine won't post at all. This is supposed to be a Dell tower server, but I have read that it makes a great workstation, and it will accept non-ECC RAM. I don't claim to know everything that is current with RAM, so maybe I am missing something, but shouldn't these 2x2GB sticks work? The machine came with 1 stick of 1GB ECC RAM and worked fine. I placed the Corsair sticks in what I believe is the correct config, slot 1 and slot 2, both white slots, and got an amber flashing light on the front, and no display. This lead me to believe that the RAM, or its configuration is preventing the machine from even posting. I then stuck just one stick of the RAM in slot 1. I'm not sure if this even is supposed to work since the RAM is dual channel. I tried that with each stick individually, and then I tried any other combination of the 2 sticks in any of the 4 slots, and always got the same thing. Plug in the machine, press the power button, wait about a minute while the fan is on full blast (possibly because the case is open), and then no POST, nothing on the screen, and flashing amber light.


I put the original 1GB ECC stick back in, and it's fine. I know that the T110 will accept PC3 10600 RAM, but these Corsair sticks are rated at PC3 10666 I believe. Could that be the issue?


Thanks for any and all help!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...