Jump to content
Corsair Community

Survivor GT 32 GB - potential fault


Recommended Posts

I received this drive two days ago. It seemed to work fine until I first disconnected it and reconnected it. Then it got stuck in a disconnect/reconnect loop.


A reboot had no effect.


I plugged it into a (Win XP Pro SP3 32-bit) laptop, and reformatted using the Panasonic utility, but as soon as I reconnected to the original desktop PC and copied data to the drive, the problem recurred.


I then disabled AVG 2011's automatic removable device scan, and have had no problem since.


The System Event log was full of the following error:

An error was detected on device \Device\Harddisk1\D during a paging operation.


Is this likely to be a faulty drive? I'll test today in a Windows 7 PC and report back.

Link to comment
Share on other sites

Thanks for the reply, RAM GUY.


I formatted it with NTFS using the Windows 7 PC. I then plugged it back into my Win XP desktop. No problem.


I copied some data onto it, re-enabled the automatic scan in AVG 2011, ejected and reconnected the drive.


Once again, it began to disconnect/re-connect continuously. This time, I see not only the error described previously, but also:


The system failed to flush data to the transaction log. Corruption may occur.


I have since disabled AVG's automatic scan, and now do not suffer the multiple disconnections. The error re-occurs, however, when I launch a manual scan.


Thanks for your assistance with this.

Link to comment
Share on other sites

  • 2 weeks later...



AVG's scan is still disabled, but now I once again get the disconnect/reconnect loop, and the error:


An error was detected on device \Device\Harddisk1\D during a paging operation.


Can you advise, please?





Link to comment
Share on other sites

  • 1 month later...



I have the same exact problem. It started by me getting corrupt information on the memory which forced me to run the check on it and that in turn removed all my info which was not so good since I use the memory as a backup of sorts. When I moved some information from one computer to another the problem reoccurred and now it mounts/remounts all the time. I can not get access to it or format it in any way!


My number is: FG29B0042


Any suggestions? Are there actually bad sectors on the memory or why is it flipping out?


Best Regards



Link to comment
Share on other sites

  • 2 months later...
Hey, I am having this exact issue, I bought it from amazon and it arrived today. Won't let me copy anything onto it, Ejects itself part way through the transfer. Have tried formatting it to multiple different file structures but have the same result. Came packed really well so it's not a damage issue.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...