Jump to content
Corsair Community

Firmware Updater to 2.0: drive not found: f120 ?


Recommended Posts



I tried to update the 1.0 firmware of my f120 with the new firmware 2.0.

But the drive is not recognized by the update-tool, I have tried multiple Boards and controllers.:[pouts:


With Jmicron it fails, with Intel ICH9 it fails with both intel and microsoft drivers, on my i3 notebook it fails, all work with AHCI.

Are there any incompatibilities with the update-tool and Win 64 bit?

Have I missed something?


On all controllers the drive works. But I have the problem that after reboot or hibernate the bios does not recognize the drive, I have to reboot.


Thank you.



Link to comment
Share on other sites

Had this problem yesterday, someone pointed me in the direction of the solution. (as odd as it sounds) you need to remove some partitions... My SSD (F120) had 3 partitions on it (a Fat16 Recovery partition, C drive [os], D drive [data(empty)]). I used Hirens Boot CD to delete the Recovery Partition and the D drive and expand C to use the whole disk. (after I made an Acronis Image of the drive).


After removing those partitions the drive was found successfully (no joke).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...