Jump to content
Corsair Community

TW3X4G1333C9A BSD/memtest errors in Dual channel


Recommended Posts



I have a problem with 1 pair of new TW3X4G1333C9A modules.

At random times my system crashes in Windows with BDS's when the pair is configured as Dual channel. (motherboard Gigabyte GA-MA770T-UD3)


So I tried memtest86 and got a lot of errors almost instantly. However weirdly at one time memtest86 ran for 8 hours without a single error. Then the next morning I ran it again with errors after 10 minutes (see screenshot)


Next step was to try the modules one at a time and they seem to run just fine (no mem errors/crashes).

Then I tried them as single channel which seemed to run fine aswell (again no crashes in Windows or memtest errors)

So I bought a new Motherboard (Asus M4A77TD) hoping this would solve all of my problems, but the same errors again keep showing up in memtest on Dual Channel and Windows is highly unstable. (single modules or double modules in single channel run fine after short tests)


I dont know why this is happening and what I can do about it to make it run stable at Dual channel??



System specs:

Asus M4A77TD (tried Gigabyte GA-MA770T-UD3 aswell)

Corsair TW3X4G1333C9A (2x 2GB)

AMD Phenom II x4 945 (95W)

Corsair 400cx Power Supply


Link to comment
Share on other sites



Thanks for the update, I got it nailed now I think with this newer version of memtest.

One of the modules fails on test #5 on alle slots after only 3 minutes. (see screenshot)

The other gives me no errors after +11 hours.


Also Prime95 is giving hardware failures with the corrupt module.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...