Jump to content
Corsair Community



Recommended Posts

Hello, a little back ground. I was using CORSAIR TWIN2X 2048-6400C4-D KIT, after 2 yrs of working they just died. No problem, its warrantied, got rma, sent it in, the replaced it with Twin2X4096-6400C5DHX G, which is compatible with my motherboard. Received it Friday, you can guess how excited i was, I was using only 1g. Installed both Modules for dual memory, slot A1 and B1, pressed the power button and NO BOOT:sigh!: removed both modules, put my Kingston 1g module in and success it booted. Powered off and tried one NEW module in slot A1 NO BOOT, tried second module and NO BOOT, you can guess some words I was using. Not only did it not boot, but now it wouldn't boot with my Kingston... well you must know how frustrated I am getting:(: left system off for about 1hr tried one more time with new module and got it to boot, and crashing... I'm not very happy right now

any help would really be appreciated, before I send back the RAM

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...