Jump to content
Corsair Community

Can HX1000W power two 480 GTX in SLI?


hv43082

Recommended Posts

I had this PSU since late 2008. I recently upgrade my my GPU to two 480 GTX. The PSU was working fine prior to this upgrade. Now it is having problem handling two 480 GTX in SLI. Each card is working perfectly by itself (Furmark stable) but whenever they are used in SLI mode (Furmark multi GPU, games) the system would crash to black screen right away and requires hard reset to get back to window. Both official and beta drivers provide the same result.

 

My PSU is Corsair 1000W. One card is connected to 12V1 and the other to 12V2. I have tried to connect both card to 12V2 but the system would freeze as soon as SLI is selected in NVIDIA control panel. When I manually lower the stock voltage of the GPU from 1.025V to say 1.000V, the system would run Furmark for 10-15 minutes before the same problem happened.

 

My system is listed in my signature/system spec. Is my PSU not enough? I have successfully use 460 GTX SLI without any problem.

Link to comment
Share on other sites

i dont see why it wouldnt be, i have seen others running specs similar to yours. i would check all your power connections and use a multimeter on teh psu to see if it is suppling teh correct amperage on teh 12v rails, if it is then it should work if not the psu has a problem and will most likely need rmaed
Link to comment
Share on other sites

According to the Corsair PSU finder the 950W-1200W Corsair PSUs will work fine for this application. The eXtreme Power Supply calculator and the Newegg PSU calculators also agree that a 1000W PSU should be fine.

 

http://www.corsair.com/psufinder/default.aspx

 

http://www.extreme.outervision.com/psucalculatorlite.jsp

 

http://educations.newegg.com/tool/psucalc/index.html

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...