Jump to content
Corsair Community

Microsoft Storage Driver, not active. TRIM enabled


Recommended Posts

I have now had my F80, (with firmware 1.1) for some time, and did the check list when i installed Windows 7.

I did set it to AHCI mode, in Bios. Before installing Windows. Enabled TRIM, after install. Chcecked that TRIM was active. It's was active. Cheched just now, still active. But is it really active, since i not have the MSAHCI, or the Intel driver installed?

I looked in device manager, i did have not the Standard AHCI 1.0 Serial Controller (MSAHCI). Was reading another tread about this. http://forum.corsair.com/v3/showthread.php?t=86400. Could not find my answer there.


I have the following controllers, when i look in Device Manager.

- AMD SATA Controller.

- ATA Channel 0.

- ATA Channel 1.

- Standard Dual Channel PCI IDE Controller.


The Bios it set to AHCI mode, for the F80, and my other HDDs.

My system specs can be seen, above.



Link to comment
Share on other sites

At the top of this section there is a sticky on how to check the TRIM is enabled did you see that post?


Yeah. I wrote fsutil behavior query disabledeletenotify in CMD. I right clicked on CMD and Run as Adminstrator, before checking.

And DisableDeleteNotify 0 was the result. So it is enabled. And i know that it set to AHCI in Bios. I set it back to IDE, and could not Boot into Windows, set it back to AHCI in Bios, and Windows boots up fine. And i have used the tweaks from your blog. http://blog.corsair.com/?p=3468

But i haven't the MSAHCI driver, or the Intel driver installed. Only a AMD Sata(AHCI driver?)

Only those you see on the picture above. Can post another picture if that helps.

Link to comment
Share on other sites

RAM GUY: Yes, have read it.


Heintz.G: No, i have'nt tried that.

I can try it, but i don't think that i had msahci before AMD Sata driver.



Ehm, we can set this one to solved. I checked now, in device manager.

AND guess what? Standard AHCI 1.0 Serial ATA-controller is there. And when i checked the driver, msahci.sys is there. With some others. No AMD driver.


I think i was looking in the wrong place. I was looking at the disk itself, not the IDE ATA/ATAPI controllers.

So this one is solved, and can be deleted :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...