Jump to content
Corsair Community

New H70 Install


Recommended Posts



I have just done a major case, fan and PSU upgrade to my computer. Specs are in my profile.


I am having trouble with the H70 with regards to what it seems the pump not working. I have tried plugging it in to various 3 pin headers and they all read it as N/A in the BIOS for fan RPM speed.


Do I have a faulty unit or have I done something wrong?


I have also tried plugging it in to a molex adapter with the fan plug lead (last resort) and made no difference.


Any Ideas?

Link to comment
Share on other sites

Check the plug on the end of the cable coming from the pump, and make sure all three metal connectors inside the plug are making contact with the power source - probably easiest to check when attached to the molex adapter.


Sometimes those little tags that hold them in place dont do such a good job, and one pin loses connection.


If its connected, faulty pump :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...