Jump to content
Corsair Community

Force 120GB not working


Recommended Posts

Hi all! I'm new to this forum. I just recently bought a Corsair Force series 120GB to use as my OS drive and put some games in it. I bought a G73JH with a custom i7-940XM and the HDD was a real bottleneck in the system. Problem is I tried to clone the HDD partition onto the SSD and it didn't boot up properly. It would boot up into windows 7 but it would take me to a temporary desktop screen and I just couldn't do anything.


So I tried taking out the SSD and trying to boot this time with the old HDD and turns out the same happened. I've no idea what's going on, I've tried to search in the forums and on the internet but can't find a solution. I've tried to reformat the drive and do a clean install but now I get a different error that says that the drive cannot be read.


I'm freaking out right now. i spent 2.5k on this setup and now it's just a worthless piece of plastic sitting on my desk. If anybody has any ideas or had this issue and knows the solution, please HELP!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...