Jump to content
Corsair Community

Nova v64 - Windows XP/7 Installation issues


Recommended Posts

I've just purchased a Nova v64 SSD and I'm trying to install it in my kids PC (HP dx2200 desktop). The HP dx2200 has a SATA I controller in it, but I'm not sure if it is using IDE ot AHCI mode - no settings in the BIOS to change the SATA mode.


From my reading in the forums I should just be able to plug the drive in and install Windows - preferably Windows 7 - no preformatting, etc.


This appears not to be the case. The dx2200 recognises the drive in the BIOS and when start the Windows 7 installation, but when the Windows 7 installation attempts to create the partitions it states that it can't create partitions and setup stops working. This has been reported previously in the forums but no real resolution.


I also tried Windows XP, just in case. The installation of Windows XP completed, but when I tried to restart after the installation NTLDR could not be found.


I decided to try the drive in my Dell Vostro and the Vostro would not install Windows 7 with the SATA controller set in AHCI mode, but as soon as I changed to IDE mode Windows 7 installed succesfully.


From my reading in the forum I thought that the Nova v64 should work in AHCI mode, not IDE mode. However I have found this not to be the case. Is there something wrong with the SSD if it does not work in AHCI mode? Or should I be looking for a SATA II controller for the HP dx2200?

Link to comment
Share on other sites

Thanks RAM GUY and dr00x.


I managed to fix the issue by purchasing a new SATA II controller. Once I managed to find the Windows 7 drivers for the SATA controller it all worked as expected.


RAM GUY for your information I had tried repeatedly to erase and quick format the partitions on the v64 with the original SATA I controller. I also tried Gparted, and another PC - all with no luck. The Windows 7 install didn't work until I installed the new SATA II controller.


SATA Controller details as best as I can figure out are:


  • Original SATA I Controller in HP dx2200 is SATA Controller that is part of the ATI Radeon Xpress 200 chipset
  • SATA II Controller in Dell Vostro 420 (only working in IDE mode) is Intel® PCH SATA AHCI Controller (PCI\VEN_8086&DEV_3B22&SUBSYS_02EC1028&REV_05)
  • Working SATA II Controller is based on a JMIcron JMB36x SATA II Controller.


I hope this might help someone else.

Link to comment
Share on other sites

Then should I understand that there is an incompatibility between the Nova SSDs and older SATA I controllers in regards with the Win7 install?

I mean for me installing on the Nova ssd worked fine on the AMD 785G board in AHCI mode but not on the older G35/ICH9R board either AHCI or IDE.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...