Jump to content
Corsair Community

P256 on new Win 7 x86 install


Recommended Posts

I own a Dell Mini 10 with an Intel Z530 CPU, 2GB RAM and a Corsair P256 SSD. The Mini 10 bios (Phoenix A11) does not allow for ahci, so all drives operate in IDE mode. For the past year I have been using the system with Win XP SP3 and have experienced absolutely no problems.


Yesterday I tried to upgrade the system to take advantage of TRIM support. I updated the P256 firmware to VBM19C1Q and did a new clean install of Win 7 x86 32-bit. Both the firmware upgrade and the installation process went off without a hitch, and I thought everything was fine.


But as it turns out the machine runs incredibly slow. This was immediately obvious from the first boot. Basic operations are sluggish beyond words and often become unresponsive for 10 or 20 seconds. Boot up times are a little longer than normal, but nothing ever hangs. Yet regular uses like opening and closing applications, especially windows explorer or any other heavy file I/O app, is slower than any machine that I have owned since the DOS age.


HDTune reports that transfer rates on my P256 under Win 7 average less than 20MB/s, with highs never breaking 50MB/s, and lows falling to 0MB/s quite often. And that seems to capture how the machine is behaving: everything is fine for a little while, then suddenly it locks up for an extended period, and eventually frees itself. Average access time was something around 0.210ms. Unfortunately I failed to save the screenshot properly, but those were pretty much the typical results after repeated tests.


I have tried all of the excellent performance improvement tips described in this forum. None have made any difference. I tried the secure erase and Acronis backup method. I tried a secure erase and another fresh install. I tried booting up Win 7 in safe mode. In each case the drive remained sluggish and often unresponsive.


I then cloned the Win 7 image on P256 to a standard 5400RPM HDD and booted it up. Guess what? The system worked perfectly, faster than I could have imagined - is if the HDD were the SDD, rather than the other way around.


So clearly there is something wrong with the way Win 7 is interacting with my P256. Right now I am reinstalling Win XP SP3 on the drive to see if it's performance has been impaired in any way.


Is it possible that the firmware upgrade caused this problem? Is there something about Win 7 and the P256 that I am missing? Is IDE mode causing this? Most reports say that the impact is something less than 10%, not the kind of results I'm seeing.


Thanks very much for the help. Any and all advice welcome!

Link to comment
Share on other sites

It worked fine under Win XP SP3. I updated the firmware before installing Win 7 x86, so I can't say with certainty that the new firmware is the source of the problem.


When I attach the P256 to an eSata port on another Win 7 x64 machine I get consistent throughput of almost 90 MB/s. So I think the drive functions well under the right software configuration.


But I have no idea why it won't run on a Dell Mini 10 with Win 7 x86. Frustrating to say the least!

Link to comment
Share on other sites

  • Corsair Employees

Install it as second HDD then quick format it with 4K allocation then test it with ATTO and post a screen shot. if its not up par then secure erase it with parted magic and format it and test again.

Once its running properly then delete the partition then image it back and test the performance.

Link to comment
Share on other sites

what controller is it on? maybe an upgrade or change of drivers would help?


Under "IDE ATA/ATAPI controllers" in the Win 7 Device Manager there are three things listed:


ATA Channel 0

ATA Channel 1

Standard Dual Channel PCI IDE Controller


These seem like stock drivers for Windows. But I don't really know much about this.


Are there other drivers available for the Corsair P256? I have looked all over the internet and haven't found anything.

Link to comment
Share on other sites

With the help of another forum (mydellmini dot com) I was able to get my Mini 10 to run with a Corsair P256 under Win 7.


The problem is TRIM. Any machine running an Atom CPU on the US15W chipset will suffer performance problems on Win 7 if the TRIM command is enabled. It's not just the Dell Mini that suffers this limitation. Any Atom based netbook will have the same trouble. Which makes me wonder why more people aren't complaining about it. The whole point of installing Win 7 is to take advantage of TRIM. Instead, if you are not careful, TRIM will take advantage of you.


The good news is that there is a very quick and easy solution to the problem. I was able to get my Mini 10 running properly with the Corsair P256 in less than a minute.


Run cmd.exe and type in "fsutil behavior set disabledeletenotify 0" at the command prompt. The problem with non-responsive sluggishness will disappear immediately. Read/write speeds will still be slow (~60MB/s) but the machine will be functional for daily use.


This episode of course raises the question of whether the SSD/Win 7 configuration should be used at all on a netbook. But I'll leave that for a another day.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...