Jump to content
Corsair Community

F120 not recognized by ICH10R


ktmchris

Recommended Posts

Just got a new F120. Put it in my system....and......system hangs in AHCI Bios scan on whatever port I place it on.

 

Changed cables and still the same result.

Change to different port on ICH10R, still same result.

Change to a Marvell Sata6G controller, works perfectly.

Ports and cables work with a ******** HDD perfectly on ICH10R.

 

I'm not interested in using the Marvell controller as my boot drive. Any ideas on how to get the ICH10R to recognize this drive?

 

Chris V.

Link to comment
Share on other sites

Actually, it was hanging literally in the BIOS Scan. You wouldn't make it to the setup menu. If you put it on Port 0, it would hang in that portion of the scan indefinetly. If you put it on port 3, it would scan 0-2 and hang on port 3 indefinetly. It would never print the name of the device....just Port 3- and nothing.

 

However, I do have it working now.....

 

I put the drive in a USB cradle and initialized with a partition, wrote some files to it, then deleted the partition. Placed the drive back by itself on the ICH10R and boom... It started working......very strange...

 

Now, I am openly skeptical right now...but, Windows is installed and Intel Matrix Manager reports a Gen 2 connection. I'll be testing more before committing myself to the drive......

 

I'll report back if more strangeness occurs.

 

KTM Chris

Link to comment
Share on other sites

Corsair Tech Support:

 

Here is how to re-create my situation.

 

1. Take Fresh drive and mount to any ICH10R port.

2. Boot and go through AHCI Bios Scan. F120 will be recognized.

3. Turn off system.

4. Mount F120 to a USB->SATA connector.

5. Run Acronis True Image Home 2010 V13.0.6063. Clone boot drive to F120 attached to USB.

6. After System is powered off, attach F120 to any ICH10R port. I've tested with a Gigabyte EP45-UD3P FC Bios and a Gigabyte EX58-UD5 F12 Bios. AHCI Bios 1.20E. Both systems will completely hang on the port you put the drive on during the BIOS scan and not recover until power off or reset.

7. Move drive to a Marvell 9123 controller. I'm using an Asus U3S6. Drive boots and run's the clone of Windows flawlessly.

8. Put drive back onto ICHR10, refer to #6. Computer Hangs during AHCI Scan.

 

This happened to my original drive and then I purchased a 2nd drive because I didn't trust the 1st. 2nd drive acts identically, so, I know this is a drive problem.

 

Other interesting observations:

 

1. If you boot Win 7 and hot plug the drive as eSata on ICH10R, the drive comes up and is perfectly usable, you can see and manipulate all of the files on the drive.

2. If you put the drive back in to the USB->Sata Cradle and erase all partitions, then put the drive back on ICH10R the drive becomes usable on all ports.

3. If you boot a Windows DVD and fresh load windows, with the drive from #2, the drive will work fine. BTW, on this note, I even loaded Intel 9.6.0.1014 driver and issued the ForceTrim command from page 5 of this http://forum.corsair.com/v3/showthread.php?t=88341 thread without any crash or problem.

4. Now, if you take the F120 with clean windows and use Acronis to clone to the 2nd F120, the 2nd F120 now hangs any ICH10R port. But, works perfectly on Marvell 9123 and USB->SATA.

 

 

So, to summarize this whole thing, you can't use Acronis True Image to clone to an F120 drive and still have compatibility with ICH10R. It seems to bring about a firmware bug that does not let the drive respond to the BIOS Scan.

 

I purchased a competing SSD which works in all of the above scenarios, so, this is definitely a F120 issue.

 

I live in the Bay Area. If you want me to demonstrate this, PM me. I'll come over and give you a demonstration.

 

Chris V.

Link to comment
Share on other sites

And now an addendum.....

 

Both F120 drives work perfectly and can be the target of an Acronis True Image clone. So, now that I've been reading / writing / deleting partitions....the drives seems to have found a normal function.

 

So, given the current state of things, my conclusion is that the drive is in a bad state as shipped. Both of my drives failed out of the box with the above test sequence.

 

Very strange issue........If anything changes....I'll update the thread....

 

Chris V.

Link to comment
Share on other sites

  • Corsair Employees

Chris

Thanks for taking the time to post this it is very helpful we are looking into this now as well as a few other reports of issues. If you are local and have the time to call in and ask for me I would like to speak with you. 510-657-8747 ask for Ram Guy.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...