Jump to content
Corsair Community

Seemingly expired 512MB Flash Voyager

Citizen Crazed

Recommended Posts

As per other thread RamGuy, my much loved (well, maybe that's a bit too strong!) 512MB original Flash Voyager appears to have written its last.


I can't write anything to it. The two files currently on it won't delete (and when one of them opens, it's corrupt. I've tried using a normal Windows format - it comes up with a "Windows was unable to complete the format" error. I tried the SD-Card Organization format utility - it comes up with an error too, claiming the drive is write-protected.


Finally I tried Yellowbeard's suggestion re. the Win9x FDISK utility. If I use this to delete the primary partition, it appears to function correctly, but on restarting the PC, the partition is still there, having never actually been deleted.


So, anything else I can try, or is that the end of the road?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...