Jump to content
Corsair Community

[help] kernel_data_inpage_error


Recommended Posts

I have a new Corsair F60. Twice now, I get BSOD saying kernel_data_inpage_error in win7 64bit while sleeping in the course of about 4-5 days. I've looked under power settings and anything relating to sending the harddisk or graphic card to sleep is disabled. min power is set to 20% as well.

 

The first time it happened I could just press the reset button and everything's back up and running. Second time it occured, again while I was sleeping, I reset the pc and could not get into windows. In fact, the device was completely missing in BIOS. I had to poweroff the PSU (seasonic) then turn on again before it appeared. Will prolly happen again.

 

I have an i3 530, with corsair 2x2gb 1600 c8 classic, gigabyte p55-us3l, running in AHCI mode.

 

i used "profile1" for the ram and it set the settings correct, and qpi link was about 7gb by default,which i lowered to 6.4. proc is at 3ghz. im gonna use default ram speeds to see if that helps but somehow i doubt it.

 

Please help, Thanks.

Link to comment
Share on other sites

Thanks Ill give that a try. I should add that it occurred not when the computer was put to sleep, and that I must have confused you with that I was literally sleeping so the BSOD didn't happen directly in front of me. It happened when the PC wasn't really doing anything I suppose.

 

That gave me another thought, doesn't Win7 auto-defrag during idle? Perhaps I should turn this off?

Link to comment
Share on other sites

Alright, I have a rough guess of what's going on now.

 

First of all, following up from the previous posts, I have swapped out (hehe secretly) my F60 ssd with another person's F60 ssd. (I purchased 3 units the same time, 1 for me, 2 for him). Formatted and setup from scratch. Had a bsod the first night already. The message was slightly different though, as if a process crashed the system. Alright, ignore that.

 

Then, what just happened was, earlier, while I was just surfing, the system become unresponsive. One program crashed, then taskbar becomes unresponsive (you see the mouse waiting cursor), after a minute or so, total black screen and only mouse cursor is movable. Not being able to do anything, I just hit the reset button, to find F60 missing from the BIOS, rendering system unbootable.

 

Next thing now, I changed the SATA cable. Let's see what happens next. The other pc with the 2 ssds at this point -- i can't make a deduction yet. I was told of 1 BSOD while using just Firefox, but he didn't write down any details for me, and he doesn't use the pc much. I need to wait for feedback.

 

I have this bad feeling this is going to happen again, so what goes from here? Bad board? I have 8 of 8 SATA ports used for other drives and only this drive causes problems. With the cable changed, only time will tell, but yeah, bad vibes still.

Link to comment
Share on other sites

  • Corsair Employees
There is no need to do that, if you have that problem and have tried to update the MB BIOS and are using it in AHCI with the latest driver then just request an RMA and we will be happy to replace it.
Link to comment
Share on other sites

OK I was right. Changing the SATA cable did no good. Just BSOD'd. I swapped SATA ports and power cables with another drive now.

 

I'm beginning to strongly believe these drives are defective. All 3

 

1 that I swapped out, 1 that I swapped in, and 1 that's on my friend's computer, as he just reported he experienced "blackscreen", which in time would evolve into bluescreen. What simply happens is, the drive shuts down and disappears from CMOS. Running in AHCI mode. You need to press the power button so that everything is off and then start again. "reset" wouldn't do anything as the SSD is still gone from CMOS.

 

Mine's a P55-US3L and he has a P55-UD4P, both flashed to the latest BIOS.

SSD is v1.0

Link to comment
Share on other sites

My F60 disappears between 12am-5am, Windows 7 64bit. Just occurred today at about 2:30am. Gonna check what scheduled tasks run in background.

 

AitAgent

ProgramDataUpdater

 

More Microsoft spyware without telling us heh. Related or not..

 

Here's the full list, someone play around with them, I'm trying too..

 

 

Folder: \

TaskName Next Run Time Status

======================================== ====================== ===============

KMS N/A Ready

SidebarExecute N/A Ready

 

Folder: \Microsoft

TaskName Next Run Time Status

======================================== ====================== ===============

INFO: There are no scheduled tasks presently available at your access level.

 

Folder: \Microsoft\Windows

TaskName Next Run Time Status

======================================== ====================== ===============

INFO: There are no scheduled tasks presently available at your access level.

 

Folder: \Microsoft\Windows\Active Directory Rights Management Services Client

TaskName Next Run Time Status

======================================== ====================== ===============

AD RMS Rights Policy Template Management Disabled

AD RMS Rights Policy Template Management N/A Ready

 

Folder: \Microsoft\Windows\AppID

TaskName Next Run Time Status

======================================== ====================== ===============

PolicyConverter Disabled

VerifiedPublisherCertStoreCheck Disabled

 

Folder: \Microsoft\Windows\Application Experience

TaskName Next Run Time Status

======================================== ====================== ===============

AitAgent 2010-07-10 2:30:00 AM Unknown

ProgramDataUpdater 2010-07-10 12:30:00 AM Unknown

 

Folder: \Microsoft\Windows\Autochk

TaskName Next Run Time Status

======================================== ====================== ===============

Proxy N/A Ready

 

Folder: \Microsoft\Windows\Bluetooth

TaskName Next Run Time Status

======================================== ====================== ===============

UninstallDeviceTask N/A Ready

 

Folder: \Microsoft\Windows\CertificateServicesClient

TaskName Next Run Time Status

======================================== ====================== ===============

SystemTask N/A Ready

UserTask N/A Ready

UserTask-Roam Disabled

 

Folder: \Microsoft\Windows\Customer Experience Improvement Program

TaskName Next Run Time Status

======================================== ====================== ===============

Consolidator 2010-07-09 1:00:00 PM Could not start

KernelCeipTask 2010-07-15 3:30:00 AM Unknown

UsbCeip 2010-07-11 1:30:00 AM Ready

 

Folder: \Microsoft\Windows\Defrag

TaskName Next Run Time Status

======================================== ====================== ===============

ScheduledDefrag 2010-07-14 1:00:00 AM Ready

 

Folder: \Microsoft\Windows\Diagnosis

TaskName Next Run Time Status

======================================== ====================== ===============

Scheduled 2010-07-11 1:00:00 AM Ready

 

Folder: \Microsoft\Windows\DiskDiagnostic

TaskName Next Run Time Status

======================================== ====================== ===============

Microsoft-Windows-DiskDiagnosticDataColl 2010-07-11 1:00:00 AM Ready

Microsoft-Windows-DiskDiagnosticResolver Disabled

 

Folder: \Microsoft\Windows\Location

TaskName Next Run Time Status

======================================== ====================== ===============

Notifications N/A Ready

 

Folder: \Microsoft\Windows\Maintenance

TaskName Next Run Time Status

======================================== ====================== ===============

WinSAT Disabled Could not start

 

Folder: \Microsoft\Windows\MemoryDiagnostic

TaskName Next Run Time Status

======================================== ====================== ===============

CorruptionDetector N/A Ready

DecompressionFailureDetector N/A Ready

 

Folder: \Microsoft\Windows\MobilePC

TaskName Next Run Time Status

======================================== ====================== ===============

HotStart Disabled

 

Folder: \Microsoft\Windows\MUI

TaskName Next Run Time Status

======================================== ====================== ===============

LPRemove N/A Unknown

 

Folder: \Microsoft\Windows\Multimedia

TaskName Next Run Time Status

======================================== ====================== ===============

SystemSoundsService Disabled Running

 

Folder: \Microsoft\Windows\NetTrace

TaskName Next Run Time Status

======================================== ====================== ===============

GatherNetworkInfo N/A Ready

 

Folder: \Microsoft\Windows\Offline Files

TaskName Next Run Time Status

======================================== ====================== ===============

Background Synchronization Disabled

Logon Synchronization Disabled

 

Folder: \Microsoft\Windows\PerfTrack

TaskName Next Run Time Status

======================================== ====================== ===============

BackgroundConfigSurveyor Disabled

 

Folder: \Microsoft\Windows\PLA

TaskName Next Run Time Status

======================================== ====================== ===============

INFO: There are no scheduled tasks presently available at your access level.

 

Folder: \Microsoft\Windows\Power Efficiency Diagnostics

TaskName Next Run Time Status

======================================== ====================== ===============

AnalyzeSystem Disabled

 

Folder: \Microsoft\Windows\RAC

TaskName Next Run Time Status

======================================== ====================== ===============

RacTask 2010-07-09 9:03:55 AM Ready

 

Folder: \Microsoft\Windows\Ras

TaskName Next Run Time Status

======================================== ====================== ===============

MobilityManager N/A Ready

 

Folder: \Microsoft\Windows\Registry

TaskName Next Run Time Status

======================================== ====================== ===============

RegIdleBackup 2010-07-19 12:43:49 AM Unknown

 

Folder: \Microsoft\Windows\RemoteAssistance

TaskName Next Run Time Status

======================================== ====================== ===============

RemoteAssistanceTask N/A Ready

 

Folder: \Microsoft\Windows\Shell

TaskName Next Run Time Status

======================================== ====================== ===============

WindowsParentalControls Disabled

WindowsParentalControlsMigration Disabled

 

Folder: \Microsoft\Windows\SideShow

TaskName Next Run Time Status

======================================== ====================== ===============

AutoWake Disabled

GadgetManager N/A Ready

SessionAgent Disabled Could not start

SystemDataProviders Disabled Could not start

 

Folder: \Microsoft\Windows\SoftwareProtectionPlatform

TaskName Next Run Time Status

======================================== ====================== ===============

SvcRestartTask Disabled

 

Folder: \Microsoft\Windows\SystemRestore

TaskName Next Run Time Status

======================================== ====================== ===============

SR 2010-07-10 12:00:00 AM Unknown

 

Folder: \Microsoft\Windows\Task Manager

TaskName Next Run Time Status

======================================== ====================== ===============

Interactive N/A Ready

 

Folder: \Microsoft\Windows\Tcpip

TaskName Next Run Time Status

======================================== ====================== ===============

IpAddressConflict1 N/A Ready

IpAddressConflict2 N/A Ready

 

Folder: \Microsoft\Windows\TextServicesFramework

TaskName Next Run Time Status

======================================== ====================== ===============

MsCtfMonitor N/A Running

 

Folder: \Microsoft\Windows\Time Synchronization

TaskName Next Run Time Status

======================================== ====================== ===============

SynchronizeTime 2010-07-11 1:00:00 AM Ready

 

Folder: \Microsoft\Windows\UPnP

TaskName Next Run Time Status

======================================== ====================== ===============

UPnPHostConfig N/A Ready

 

Folder: \Microsoft\Windows\User Profile Service

TaskName Next Run Time Status

======================================== ====================== ===============

HiveUploadTask Disabled

 

Folder: \Microsoft\Windows\WDI

TaskName Next Run Time Status

======================================== ====================== ===============

ResolutionHost N/A Ready

 

Folder: \Microsoft\Windows\Windows Activation Technologies

TaskName Next Run Time Status

======================================== ====================== ===============

ValidationTask N/A Unknown

ValidationTaskDeadline N/A Ready

 

Folder: \Microsoft\Windows\Windows Error Reporting

TaskName Next Run Time Status

======================================== ====================== ===============

QueueReporting N/A Ready

 

Folder: \Microsoft\Windows\Windows Filtering Platform

TaskName Next Run Time Status

======================================== ====================== ===============

BfeOnServiceStartTypeChange N/A Ready

 

Folder: \Microsoft\Windows\WindowsBackup

TaskName Next Run Time Status

======================================== ====================== ===============

ConfigNotification 2010-07-12 10:00:00 AM Ready

 

Folder: \Microsoft\Windows\WindowsColorSystem

TaskName Next Run Time Status

======================================== ====================== ===============

Calibration Loader Disabled

 

Folder: \Microsoft\Windows Defender

TaskName Next Run Time Status

======================================== ====================== ===============

MP Scheduled Scan 2010-07-10 5:07:31 AM Ready

 

Folder: \OfficeSoftwareProtectionPlatform

TaskName Next Run Time Status

======================================== ====================== ===============

SvcRestartTask Disabled

Link to comment
Share on other sites

if you have that problem and have tried to update the MB BIOS and are using it in AHCI with the latest driver then just request an RMA and we will be happy to replace it.

 

I do run AHCI.

I have not tried to update the bios as the only later bios only gives compatibility with more ram modules.

 

I have installed the latest Intel drivers, but as I stated in my other post:-

 

Drivers cannot affect the sensing of the disk in bios.

 

Derek

Link to comment
Share on other sites

Update: My friend's pc just had that KERNEL_DATA_INPAGE_ERROR bsod at 3:30-3:45am. His is an entirely new pc, and mine's a semi-new system using 100% working parts from my previous pc.

 

Alright RAM_GUY you gotta help me out here. I highly doubt it's cable, controller, power issue now.

 

It can only be windows 7 doing something that ssd dont like in background... or something's not right with this SSD.

Link to comment
Share on other sites

How will I know this won't happen again? For 3 drives to have this issue, it can only mean the product is faulty by design. There are others with similar complaints although for other models. Is there a newer revision? Mine's 1.0. It will be a lot of trouble as the drives are used as system drives so I need the confidence that replacement would fix it.

 

One more thing, I'm from Malaysia and I purchased this directly from a Corsair distributor as I have an account with them.

 

I do hope I can setup some kind of "credit" replacement so that I replace first, and then return. (My distributor knows me personally)

Link to comment
Share on other sites

  • Corsair Employees

You would need to talk to the reseller if you wanted to get credit, all we can do is to replace the drives. Sorry.

And as far as I know there is no problem with these drives and no newer versions.

And I would talk with Microsoft about the error log you posted looks like there may be a bug with that software.

Link to comment
Share on other sites

I have had thise 2 F60 allmost a week now and nothing like that have happend to me. However some games from Steam have crassed my pc, but BIOS have allways bean apple to find ssd on Raid. And i think my problem is more on software then hardware.

 

I have Intel Chipset on my board for sata's and i downloaded those drivers directly from Intels website, so they are much newer then those on mb's website. Have you tryed them?

 

- Not that it would help BIOS to look that drive, just that windows wouldnt crass in firsth place to make it lose them...

Link to comment
Share on other sites

ill keep an eye and keep posted, im stable 4 days now after swapping ports and disabling some task schds. ssd no longer Port0 Master, Now Port 1 Master I think.

 

Waiting for feedback from the other pc.

 

Keep this thread open for a while until things are stabilized.

 

Also, before coming here, I did post in Microsoft socialnet. I need to say, Microsoft tech are incompetent and clueless.

Link to comment
Share on other sites

  • 2 weeks later...

Captain RAM_GUY: Gotta tell you, I don't see anything foul in SMART, but what I can tell you is, I got my first BSOD on its very first day. A few days later, I swapped the ssd with another ssd and same stuff still happened.

 

I'm however pleased to hear that corsair is working diligently on this matter. I emailed sandforce about this and it's good to know that they are working with corsair to work this out.

 

I think this issue is outside our hands now, and that we can only wait for you folks to come up with a solution because after laying all the cards on the table, I can only finger point at firmware or defective by design. There's no possibility of anything else. SSD is after all a new product.

 

What I would like to hear is what are Corsair's plans regarding this matter. Are we supposed to _SUFFER_ these consequences for another few months? Is there a specific timeframe for Corsair to come up with a solution before which they come up with some form of refund or replacement or I don't know. You know this can go on for another month and it ruins my sleep. I wake up in the middle of the night, I see a BSOD, I have to turn computer off and restart and reopen my stuff. Then i can't go back to sleep. So yes, it's a big problem. Make a timeframe, after which Corsair must make a form of compromise or sacrifice.

tmp-corsair1.jpg.4816e80fd3dc20aedb3e7a84b032f00a.jpg

Link to comment
Share on other sites

  • Corsair Employees
At this time I have no information to tell you, other than what has been stated previously. We are looking into the issues but it seems that most are not having problems so its a small % that do. However, when there is any new information it will be posted.
Link to comment
Share on other sites

  • 3 months later...
We've found the problem for you. Read the other thread. The small % that do is because we have TRIM while the major % probably don't know what TRIM is.

 

Actually TRIM is completely unrelated. Most people do run TRIM and probably don't know it because it's enabled by default in windows 7 even if you installed with a spinning HDDD.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...