Jump to content
Corsair Community

32GB Flash Voyager GTR Unreadable


iamstuck

Recommended Posts

I purchased a 32GB Flash Voyager GTR a few weeks ago and it worked well for a while. I can no longer get any of my machines to recognize it and the blue light just flashes endlessly.

 

Windows 7 displays it as a "Removable Disk" and won't allow me to reformat it. Diskpart shows the following:

 

Disk ### Status Size Free Dyn Gpt

-------- ------------- ------- ------- --- ---

Disk 2 No Media 0 B 0 B

 

I have tried a number of tools listed in these forums to make it usable again, with no luck.

 

Can someone please help me restore access to this drive? I had sensitive financial data on here and really don't want to RMA the drive. It's also the second Corsair flash drive I've had in the last couple years that failed on me pretty quickly and am very frustrated (i.e. pretty ready to abandon the Corsair brand).

 

Thanks in advance for any assistance.

Link to comment
Share on other sites

  • Corsair Employees
I am sorry that happened but we do not offer data recovery, you can contact a third party to try and recover the Data but I would suggest getting the RMA number and speaking with our customer service by phone to authorize that before you let the third part destroy the drive.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...