Jump to content
Corsair Community

Dead voyager GT 16gb


Ferah

Recommended Posts

When i plug it in to a USB port, the computer does not recognize it or react at all.

While plugged in, windows will make the "device disconnected" sound once every 70-72seconds and at the same time the device appears in the Unspecified category in the computer as Removable Disk, but disappears within a second.

The LED flashes rapidly about 5 times every 70 or so seconds, but not at the same time as the disconnect sound.

The device can be found in the Device Manager, but when i try to get the volume information i get the error "volume information for this disk cannot be found.".

I have tried a couple USB recovery tools but none of them can even detect it.

I have tried the USB drive on several different computers with both windows 7 and windows xp and it is the same result.

Since i have personal and sensitive information on the drive i would appreciate any help i can get to at least destroy the data on the drive as i would prefer to not send it away to get a replacement while all data is on it.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...