Jump to content
Corsair Community

6 GB seen (4 gb usable)


Recommended Posts

I'm using


Gigabyte GA-X58A-UD3R motherboard BIOS Version F5 2010/03/12

3 x 2gb memory kit CMX6GX3M3C1600C7


The bios only sees 4 GB.

Win 7 64-bit says 6 GB (4 GB usable)



The system seems to be running fine. I just built it today.

I removed the CPU and checked the pins carefully and I see no bent pins.

I moved the memory sticks around with no change. If I run dual channel the bios only sees 2 GB. Triple channel 4 GB.

I loaded optimized settings in the bios. Seems very stable.


So why can't I see 6 GB with Win 7? bios? bad memory?

Link to comment
Share on other sites

Got exactly the same problem yesterday... but my computer on the other hand have been running with 6Gb in the last 8 months... I just rebooted and... it just showed 4Gb Haven't got it back since then, several reboots and I have also tried to move around the modules, no luck so far.


Have these specs:

Asus Rampage Gene II

3 x 2Gb TR3X6G2000C8GT

Win7 X64


The BIOS only says 4Gb

Win7 x64 only says 4Gb

But! Everest says 6Gb


So iam a bit confused...

Link to comment
Share on other sites

When I'm in BIOS menu it only see's 4 GB. I placed them in SLOTS 3-1, 3-3 and 3-5.

Memtest sees 4gb and passed with no errors; however it does report memory in all 3 slots!

For single the manual says 3-1 or 3-3. Bios does not see slot 3-1 but does see 3-3 and 3-5. So the BIOS sees 3-3 and 3-5 as dual channel; not triple channel.

CPU-Z sees all 3 slots as well as Win 7 64-bit. Since the BIOS only report 4 GB Win 7 reports 6 GB ( 4GB usable).


I tried flashing the BIOS with a couple different versions; same thing.


So my next step is to talk to gigabyte. Good thing I have a 1 year insurance on the motherboard from microcenter.


This sound more like BIOS problem then anything else. Slight chane of being motherboard(bent pins or bad memory controller.


However, this rig is a monster that I built. Win 7 performance are maxed in all areas (7.4-7.5) except for the sata drive 5.9. If I had an SSD drive this would fly!


I ran Dragon Age with max settings. OMG I have never seen such beautiful graphics.

Link to comment
Share on other sites

Have you tested one memory module at the time in each slot?


I just did that a couple a minutes ago and guess what! One of the modules didn't even reach POST :S in the first pair of slots, e.g. A1 B1 C1 for my part.


So try that if you haven't :)


From my point of view it looks like a faulty memory :(... have already done two RMA's in the last 3month... *sigh*

Link to comment
Share on other sites

I tried each module to see if it would post and each stick would post.


I'm running at 1066mhz. I'm not sure what to do next. Should I go with another motherboard and memory?


Maybe I'll try the Asus P6X58D PREMIUM motherboard.


At this point I just want an X58 motherboard that works.

Link to comment
Share on other sites

I did some more research and it seems that the bios or Win 7 reserves part of the memory for what I don't know. But I think everything is running fine. I'm running ATI Crossfire with two ATI Radeon HD 5770. Maybe some of the memory is reserved for graphics and other items. I'll do some more research and find out exactly what is reserved.
Link to comment
Share on other sites

thats awesome you got it all squared away. im also happy that microcenter was your store, if yours is anything like the one in NJ here they should take great care of you. thats why ive spent nearly 10 grand there since they opened 2 years ago.

again, congrats on your success!!

Link to comment
Share on other sites

Well yes its working. But once in a blue moon it posts with 4 gb instead of 6gb. SO I reinserted the memory stick and it boots fine. I've read where others have seen this problem too where it posts with less then what you have but only onece in a while. Seems kind of fussy . I still think all the 58 boards still need to be tweeked in the bios.
Link to comment
Share on other sites

Ramguy thats exactly what I did. I loaded XMP setting then set the times manually.

7-8-7-20-2T Now the DIMM and QPI voltages are a differnece of .325.

So far so good. One more test in the morning. First boot of the day will tell me.

Link to comment
Share on other sites

  • 3 weeks later...



Did you find a resolution for this problem? I'm experiencing the exact same symptoms with the BIOS registering either 2gb or 4gb of RAM only on the first boot in the morning (oe. when the PC is physically cold). After a month or so of trying just about everything I could find and was suggested to me I took it to a local comp shop who said that the RAM was faulty and that they couldn't reproduce the problem with the kit they had there (which was an OoCcZz something).


What I've tried:

  • RMAing the mobo because of a bent pin
  • Reseating the CPU multiple times
  • Adjusting and remounting the heatsink
  • Reseating the RAM
  • Trying each RAM DIMM individually - the computer wouldn't boot the first time with each single stick of RAM (ie. when they're cold) but was fine after a reset
  • Using the XMP profile
  • Manually setting timings
  • Manually setting voltages (VDimm, QPI/Vtt because of the ratio, etc)


So, I stumble across this thread while researching the RAM kit that I wanted to buy as a replacement which has me kind of worried again that maybe a new kit won't help.


Here are my specs:


Intel Core i7 920
Gigabyte X58A-UD3R
G s k i l l NQ 6G Kit DDR3 1600
Gigabyte Radeon HD5870 [R587UD-1GB]


PS. Why is the competition filter so OCD. :|

Link to comment
Share on other sites

kjalidav: Troubleshooting Thread for Incorrect Memory Amounts on X58 and P55/H55/H57 Platforms


Also, as per the rules of the forum which you were directed to upon creating an account here, please do not go around the forum filter. The same rules will answer your question about the filter.


Appologies, I thought it was kind of important for diagnostics. >.<


I've been through just about everything on that list, and given that it supposedly worked fine (I'm not sure I really trust the techs at the comp store but anyway) with their 1333mhz kit I'm inclined to think it's faulty RAM. But then as I mentioned I stumbled across this thread while researching the RAM I was thinking of buying.

Link to comment
Share on other sites

Hi guys,

Ive been planning to respond to this thread for some time now. I finally got my rig running problem free.


My recent build suffered from 2 problems. The first was very fustrating. My computer would not POST after a full shutdown (memok button booted). This was solved by purchasing a new MB. Finally after having a computer that booted problem free I was very sad to find that only 4GB of my 6GB would show after a cold start (shutoff over night). Restarting and subsequent starts showed all 6GB.



I realized I had this problem with the first defective MB but didnt know it was its own issue.


Bios and windows7 showed 4GB. CPUZ showed 6GB but in slots 1,2,3 which was very weird. I use slots 1,3,5.


I was ready to get a third new MB. Decided to purchase new ram. It was the ram.

The first set was ver7.1. The new ram was ver3.2. I cant find anywhere what version means. Can someone who knows explain to me?


I hope this helps someone. Im not saying this is your solution but it was for me. I remounted heatsink countless times, checked pins, checked tension. Important, each stick of ram worked fine individually and in any of the slots.


This was my first build in 10yrs. I was planning for a smooth build. I guess it was fairly smooth and enjoyable other than the ordeal with both a bad MB and bad RAM. Goodluck evryone.




ASUS P6X58D Premium

I7 930

Zalman 9900

Corsair Dominator TR3X6G1600C8D

Corsair HX850w


Link to comment
Share on other sites

Hi Guys,


Same issue here 6 installed sometimes posts 4, I have noticed this is a very common issue with this board and memory. I have tried everything including calling ASUS and they said for me to try to set the timing and frequency to the memory requirement - haven’t tried that yet.


One thing i noticed that no other person mentioned, I had the system running for about 6 hours on 6gigs and then got a blue screen of death and computer rebooted and posted 4 everywhere except CPU Z. If i open the case and take or switch the memory around its back to 6 gigs for a few hours or until i shut it down overnight.


can anyone help as to how i should set up the timing and the frequency for




That way i will try that and post the results for other.




my specs



my specs


ASUS P6X58D Premium


Intel Core i7-930 Bloomfield 2.8GHz

Enermax 720

GeForce GTX 275 OC 896MB GDDR3 PCIe 2.0

Link to comment
Share on other sites

Have you tried raising the QPI voltage slightly or the XMP profile yet?


Thanks for the help


i don't have much experience with setting that info.


if i can find out what i should set it at i can give it a shot.


in bios everything is set to auto - posting at 1066



Link to comment
Share on other sites

Update: I reached out to Corsair directly and they told me to do the following:




"Please load XMP if you have not already done so. If you continue to have issues test each module individually in the slot furthest from the CPU.


Thank You!"




I tried that and it did not help however i switched the dims around and it posted 6 again with XMP On (this automatically adjusts the memory) lets see how long it holds for.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...