Jump to content
Corsair Community

Write Protect Error/Issues


Greenzel

Recommended Posts

I purchased a 64gb Flash Voyager GT drive from Dell about a month ago. Initially, it worked great, ran fast & I was happy. But yesterday, I plugged it into my home computer (where it always ran fine in the past) and I got the "write protected" error. This allowed me to access the files that are already on the flash drive, however, I cannot add any additional files to it. Frustrating? Yes! I paid $200 for this thing...

 

Called Dell. They don't want to help me. Said it's been 21 days, so I am out of luck on a refund. Yeah Dell, thanks so much.

 

So after researching in these forums & other areas online, I have found that this issue seems pretty common with Corsair flash drives (not just the 64GB size either)

 

I have tried the software provided to reformat it, but the program doesn't recognize my flash drive at all, thus, I cannot use it.

 

I requested an RMA number so I can exchange it. But I've noticed in looking at these forums that Corsair's only real response to this error is to replace it. I've seen nothing about whether or not Corsair is researching this issue on their end in order to better solve the issue or at least create better products in the future.

 

What is happening at Corsair to address this issue? I'd like to hear more about it & know that this company cares about the frustrations of their customers...

 

Thanks!

Link to comment
Share on other sites

If you had read my post all the way through, you'd see that I have already put in an RMA to get it replaced (slow system by the way, 2 days later & I am still waiting for a response)

 

Thanks for proving my point with your canned reply. Again, I've not heard from Corsair on whether or not they are actually looking into & taking any action on this very common error.

 

Does Corsair care about their product reputation at all?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...