Jump to content
Corsair Community

Do you need total data destruction before RMA?


Recommended Posts

ok, so the title needs work...


the following post was done on a USB 512Mb flash drive, my system drive is on D:\ so my flash drive is installed with the letter C:\


this is a destructive program so make absolutely sure you select your flash drive not your system drive by accident!!!



if you are going to RMA a flash drive or the like and dont want to have any data on it this may help actually fix the drive as well.


if you have ever heard of or used a HEX editor this little app is fantastic and simple.


first download HxDen... http://www.general-search.com/fileinfo/7443224a

then follow my instructions to the letter and you will be either working again or ready to send the drive back.


ok, open this. attachment.php?attachmentid=6680&d=1269210898


select your flash drive or equivalent. attachment.php?attachmentid=6681&d=1269210903


uncheck the read only tic box attachment.php?attachmentid=6682&d=1269210913


say ok to the warning as you WANT to do this :) attachment.php?attachmentid=6683&d=1269210918


then click edit and select all attachment.php?attachmentid=6684&d=1269210922


then select fill selection from the edit menu attachment.php?attachmentid=6685&d=1269211045


just hit ok attachment.php?attachmentid=6686&d=1269211054


you will see this attachment.php?attachmentid=6687&d=1269211060


then click save attachment.php?attachmentid=6688&d=1269211064


yes we want this :) attachment.php?attachmentid=6689&d=1269211069


now the waiting... depending on the size of your drive this may take a while, my 512Mb drive took 13 minutes to complete the process but it will be worth it. all the zeros MUST TURN BLACK!!!


then do NOT close the program!!! YANK out the flash drive first THEN close the program!!!


once you do this, put the drive back in and try to open it, you will get this message attachment.php?attachmentid=6691&d=1269211130


you can go ahead and try to format it. at this point it will either be restored factory fresh or at the very least its ready to RMA without worrying about having your data in someone elses hands.


i hope this helps when other apps fail.






Link to comment
Share on other sites

  • 2 months later...

when did you see access denied? at install or using the tool?

this method is an option and not a Corsair tool, it does do the job though unless there are other circumstances which i will help address if i can.

please let me know ok?

Link to comment
Share on other sites

  • 3 months later...
  • 9 months later...

nice 10 month resurrection ;)


sometimes flash drives cannot be formatted due to errors in the "bits"


this app i linked rewrites all 0's to every last bit leaving it in complete unformatted totally wiped condition so if the bits that allow it to be recognized are incorrect this sets them all in factory new state.

Link to comment
Share on other sites

  • 1 month later...
  • 2 months later...
I am receiving an out of memory error when doing one pass writing zeros. Any ideas as to why? Also when I go to save I get invalid access to memory location even.


Edit: The zeros don't turn black why is this?


same error occures....:confused:

Link to comment
Share on other sites

the zeros turn black after a while depending on the drive size a longer while.

i cant say if it makes a difference but i have only used this tool under XP SP2.

if windows 7 memory management handles the instructions differently i apologize and feel bad you guys are getting these errors, i have used this dozens upon dozens of times for my job (i fix copiers/printers for a major dealer) and the only times it has failed on me is if the drive is totally porked and nothing can save it anyway so i will keep a lookout for any new app that works more reliable under newer operating systems.


there are may other hex editors out there i just stopped looking after this one worked so well for me (as you can see in the pics i posted.)


thank you for the feedback and i will update this thread once i find a more reliable one under windows 7.

Link to comment
Share on other sites

ok, one thing you can try is instead of selecting all the hex code try only selecting a couple thousand rows of bytes at a time and erase the drive in chunks following the same steps as above.


please let me know, this should avert the out of memory error.

Link to comment
Share on other sites

  • 3 months later...
  • 1 month later...
  • 3 weeks later...

Ok folks, any help is greatly appreciated.


I have the same problem with my Corsaid Flash Survivor 32GB, purchased from TigerDirect about 2 years ago.


It's telling me that it's write-protected everytime I try to delete anything on it. I was going to send it in for replacement, but wanted to wipe the drive first. Only problem is that I can't do anything with it. Can't wipe it via formatting it, erase it, over-write it or anything.


I really don't want to send it in with some personal info on it and I would really like a replacement for it since I spend over $100 on it.


Any ideas? I've tried the step-by-step instructions with the Hex program, an SD formatter, windows formatter, Eraser program, etc

Cannot do anything.


Thanks in advance!



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...