Jump to content
Corsair Community

Report Your Success or Failure - X-Series Firmware Update


Recommended Posts

  • Replies 301
  • Created
  • Last Reply
i cant even make a bootable usb, i follow instructions how to do it, but i dont see any hidden files in the usb that says in guide, tried booting it but doesnt work


got it booted up, error, failed to load etc




Using Asus M4A79XTD EVO



Link to comment
Share on other sites

tried half hour ago to update firmware...made usb bootable, switched to ide chanel, booted but when i select my corsair x32 i get download failed. i`ll wait for a better version no rush for me in this moment. i`m using secure erase with gpart. i just wanted to post this for future development. my specs are: acer aspire 8920g




Lowercase x32 on Acer Aspire 8920g. First try I got download failed. Today I tried once more and got download failed. Then I removed my second hdd and swiched ssd to that sata port, in bios always with ide chanel and after that: SUCCESS > firmware 2.0 . Now I have a question: if I have turbo memory trim is still enabled? And after update at 2.0 do I have to do something else to enable trim in windws 7 or is enabled by default ?


PS: no data lost during update

Link to comment
Share on other sites

Thank you, Corsair, for letting us try this.


Yellowbeard, do I detect a note of pessimism in your post above telling us the quickest way to get updated if this flash fails is to RMA the drive? Will the Koreans continue working on the updater, or do we take it that they are throwing in the towel? I don't mind waiting, if they are still trying. The occasional secure erase is much better than waiting for the mailman down here at the bottom of the world!


For what it's worth, I have tried unsuccessfully to upgrade one of my X256 drives from firmware 1.1. I tried on three separate motherboards, each using AHCI and IDE mode in turn, SSD attached to 1st SATA port, nothing else attached to machine. In each case it was [ERROR] Firmware download fail! Bye. The first try did actually do something to the MBR, as following that the computer would not boot from the disk. Fourth and final attempt was immediately after a secure erase.


Acronis put it all back together flawlessly, and it is back running happily - not 'bricked'.


Motherboards tried so far are: Gigabyte GA-MA790FXT-UD5P (AMD), Gigabyte GA-EG31MF-S2 (Intel), Asus M2N68-CM (AMD).


And, it so happens I have a ASUS M2N32-SLI available, which I will try when I can dismantle it for a while.


Edit --> No, failure exactly as the other mobos. It did seem to take longer before falling over, but it was just teasing. No damage done, and the system reboots no problem.


Just for luck I may try my other X256 which lives in my laptop - but I don't hold out much hope. I'll report back when/if I try it.

Link to comment
Share on other sites

Two questions. I know TRIM will not be supported in RAID configurations until the controllers get updated. Once the controllers get updated, we would still need the drive to have this new firmware too right?


My other question is, is there a thread somewhere where the differences between Garbage Collection and TRIM are discussed in depth? I know this firmware does not have garbage collection, but I would still like to learn more in general. Also, I don't suppose you may have heard anything concerning a future update where garbage collection is implemented, or is that just a pipe dream with no chance?

Link to comment
Share on other sites

Tried the update. Failed the first time but worked on the second try.


Running an Asus P6T Deluxe V2 w/ Corsair X32 1.0 on SATA port 0...


  1. Made bootable USB w/ lower32.exe
  2. Changed HDD BIOS setting to 'IDE' and 'Compatible'
  3. Booted USB
  4. Detected drive and selected '1'
  5. Got [ERROR]Firmware download fail!
  6. Removed cable from SATA 0 and plugged it into SATA port 1
  7. Ran lower32.exe again and selected '1'
  8. Got 'Firmware download successfully completed!'


Also I have attached a screenshot of CrystalDiskInfo after the flash...

How bad is the 'Intial Bad Block Count'?


Thanks and I hope this helps some people.


Link to comment
Share on other sites

I have another system (mothballed ATM) which I will resurrect and see if there's any success using that configuration.


It is interesting to note the number of failures on so many different configurations - I would have (perhaps wrongly) guessed that it would have panned out at 50/50.


Would it be more helpful for people if this section were split into two parts - one for successes and one for failures? It would help everyone and perhaps also help to narrow down the potential cause of so many failures ;-)

Link to comment
Share on other sites

Interesting, in a way, that I have failed using the same motherboard that Ramguy has succeeded with. Mine was trying to upgrade x256 from fw 1.1 - lower256.exe. RG didn't say what he upgraded, nor how it was set up.


You can see why they were reluctant to release this to the wild. It appears as though it's not random failures, rather, random successes! Bad luck, eh?

Link to comment
Share on other sites

i can report success: X32 successful in the first run, X128 i reported failure.

i changed to the sata-port, which i used successfully for the X32 and voila also satisfaction with X128. mb is asus p5q deluxe, both drives lower cases.

Link to comment
Share on other sites

Failed on the following 3 systems:


System 1 see system specs. - ICH10R


System 2 is based on an Asus P5Q Pro with E8200 CPU - ICH10R


System 3 is based on a Asus P5E-VM HDMI with E8400 - ICH9R


Success with my lower case X128 on a Gigabyte EP45-UD3R witn E6300 CPU - ICH10R


All were set to IDE mode.


Got an X32 and X64 that I am going to have a play around with on this system to see the sucess rate on the system that worked.

Link to comment
Share on other sites

OK tried a different system - configuration completely different.


MSI motherboard

512mb Ram

GForce 9600 graphics

Core Duo Intel


Blam!!! same result - failed!


It would be interesting to know the successes and failures percentage in the variance of UPPER64 and lower64 ... which fails the most or are they level pegging?


The one thing I did notice on this current trial system was that it took much longer for the drive to be identified and also for the fail to show up (at least 30 seconds) .... on my main system the search was instantaneous as was the fail result.


I think we need Sherlock Holmes lol ;-)

Link to comment
Share on other sites



Just an update to my report a few posts up.


I went back in and tried again on my Asus P5K SE (Intel P35), this time I hot-swapped between some other SATA cables and I think it worked on either SATA1 or 2. Anyway it's done, I'll keep testing the drive for a couple of weeks before re-building my new system with Windows 7 on it.

Link to comment
Share on other sites

i cant even make a bootable usb, i follow instructions how to do it, but i dont see any hidden files in the usb that says in guide, tried booting it but doesnt work


Don't worry if the files are not visible. Windows hides them by default. You can confirm this by changing file and folder options and telling Windows not to protect system files (seperate from the view hidden files setting) - I'm on a linux PC right now so can't tell you the exact wording of the options.

Link to comment
Share on other sites

Well as i run in raid 0 the firmware does not really interest me for the moment but as i have 2 x 128 ssd's i thought for no other reason than to try the update on both of them.


Imaged up my partitions on the raid0 and then went about unraiding the drives.

In the bios set it to IDE Compatible and then ran sercure erase using parted magic.


Booted to usb with the lower128 firmware.


Ran the command and both drives showed up with Rev 1.0

Flashed the first drive = success

Flashed the second drive = success.

Both drives now showing Rev 2.0


Mobo is a Asus P6T Deluxe V 2


So from my end all was successful. Have since set my drives back to raid0 and re-imaged back to where i was.


Hope some of you guys have better luck too as its not working for all for sure.

Link to comment
Share on other sites

Succesfully flashed my X128 drive. Needed to change SATA sttings in the bios from AHCI to IDE for flashing (drive was not found while in AHCI).

No data lost everything work perfect.


Lower or upper case?

Could you tell us MB name? thx

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...