Jump to content
Corsair Community

Troubleshooting a CMFSSD-64GBG2D


sbattisti

Recommended Posts

Hi folks,

 

I have a new home-built Windows 7 machine (specs in my profile). I run the OS and applications off of the Corsair CMFSSD-64GBG2D.

 

Since setting up this machine in October, in general it's been awesome. But on a few occasions, the OS began responding incredibly slowly, eventually forcing a manual power-off (had to hold down the power button, because nothing would respond). For some time, I couldn't even get the OS to boot, even in Safe Mode. I ran Windows repair, and it didn't work. Then, it magically started working again for no particular reason.

 

This happened again on another occasion, and this time it started working as soon as I ran Windows repair. Last night, it died again, but now it won't even boot to the OS. After booting from my Win 7 DVD, it can't even recognize the partition.

 

So, at this point, I'm suspicious that the SSD drive has gone kaput. The thing is, I've never owned an SSD drive, so I'm not sure. Does this sound like it's likely a problem with the SSD? I opened up a ticket with Corsair this morning, but I haven't heard back yet.

 

Some notes:

 

  • I have not touched the firmware on the SSD since buying it in October 2009
  • I have not touched the firmware on the MOBO since buying it in October 2009
  • I have not tweaked any settings in the MOBO BIOS
  • I have not tried a different SATA cable with the drive
  • I saw the thread on the new Samsung firmware update, but I'm not very knowledgeable about SSDs or hardware and can't tell whether or not that would apply to my situation (Do I have x86-based hardware? Is my SSD the "P-Series"? Can my MOBO boot and run Microsoft DOS 6.22 or 7.0 and be able to see a SSD Drive set to IDE Mode?). I have also not tried a different SATA cable.

 

Basically, everything I have tried so far has been at the OS level.

 

Any suggestions for how to troubleshoot this? Unfortunately, I don't have any other machines with SATA connections, so I can't swap it into another machine...

 

Please bear in mind that I'm a not a hardware whiz, so please use small words. :D

 

Thanks!

 

Steve

Link to comment
Share on other sites

I would suggest you:

 

Do a full backup of the SSD.

 

Flash the firmware. Your system is fine for flashing the drive. Just use the guide.

 

Retest the drive.

 

Thanks for the quick response! :D Not to be totally daft, but how can I back up the SSD when I don't have a functioning OS?

 

(I do have a complete image of the drive using Acronis TrueImage, but it's from a few months back, so I'd certainly like to get a shot at a fresh image before I go wiping. Won't kill me if I have to restore from that image, though.)

 

I have a flash drive all prepared to flash the drive, using the sticky thread here.

 

Thanks!

 

Steve

Link to comment
Share on other sites

Can you make a new Acronis image?

 

It doesn't appear so, as I can't currently boot at all, and therefore I can't run Acronis (the software is on the potentially faulty SSD drive).

 

If I had another machine with a SATA connection, I could move it there and give it a try, but I don't. :(

 

Also, the firmware flash says it's only for x86 based hardware. Isn't my Processor 64-bit, which makes it not-x86 based?

 

Or is there another firmware flash somewhere?

Link to comment
Share on other sites

your processor is both x86 & x64 compatible, but you need to know if you have a x86 or x64 version of your OS installed. You should see which version on your installation cd if you are not able to boot at all.

 

It's definitely 64-bit Windows.

 

Now, after much finagling with my Windows Recovery Disk, I've managed to get it to boot to the desktop. Don't really know how. :S I'm trying to run a backup of everything, and then I'll consider upgrading the firmware on the drive...

Link to comment
Share on other sites

Alright, I was able to flash the firmware. Everything appeared to work fine. I even ran the program again just to see if it told me I was already on the newer firmware (confirmed).

 

Then I booted from my Acronis recovery disk and restored an image onto the SSD drive. Purportedly successful. Then I reset my boot order through the BIOS to boot to the SSD. Nada. The BIOS tells me:

 

BOOTMGR is missing

Press Ctrl+Alt+Del to restart

 

The BIOS detects the drive, I can see it in the BIOS.

 

A quick google shows lots of people who are having this problem with Windows 7 and restoring from Acronis to a SSD drive. So, I'll chase my tail about that for a bit. :P

Link to comment
Share on other sites

OK, so the system is back up and functional.

 

I'm pleased with that. However, remember as well that my system has kind of "self-recovered" on numerous occasions before, only to die again even months later.

 

So, we'll see what happens from here. Any other ideas?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...