Jump to content
Corsair Community

Voyager 16GB and Voyager 16GB Mini FREEZES on XP64


Lope_

Recommended Posts

I've got the Corsair Voyager 16GB (full size) and the Corsair Voyager Mini 16GB.

Both formatted with NTFS. Connected directly to a USB port without any hubs.

 

They both work really fast on my XP32 computers. But I have a XP64 Desktop and a XP64 Laptop, both flash drives have freezing problems on both XP64 computers.

 

If I try copy a large file to the flash drive (for example 200MB), whatever program I'm using (Windows Explorer or Total Commander) will freeze until the file has finished copying. I can't browse the flash drive while its copying, and often can't browse files on my own PC either while its writing to the drive.

 

The desktop is a Core2Duo E4400 2Ghz with 2GB DDR2 800 RAM. The laptop is an Acer Extensa with a Celeron 1.86Ghz CPU and 3GB of DDR2 667 RAM. Running XP Professional x64 2003 Service Pack 2.

 

There is nothing wrong with my XP64 computers. When I connect my 1.5TB Seagate hard drive up via USB2 I copy files at around 60MB/s and I can still browse the hard drive, or my own hard drive while its busy, and nothing freezes. I can also connect other flash drives and copy large files to them without them freezing. I have a ******** 4GB flash drive that can write at 8.7MB/s, no freezing problems.

 

I have tried setting the drive policy in Device manager to Optimize for Performance, and for Quick Removal, neither setting makes any difference.

Tests are done with anti-virus disabled.

 

The corsair flash drives are really fast, but I use the XP64 PCs as my main workstations and the freezing is unacceptable.

I have searched the microsoft site for updates relating to USB on XP 64, nothing came up.

 

I have not tried formatting as FAT32. I need to store files over 4GB so thats not suitable.

Should I try different size clusters etc? (NTFS)

Link to comment
Share on other sites

  • Corsair Employees
To test the drive I would suggest trying it with the drive formatted to Fat32 and see if you have the same issue but more then likely it is the controller limiting access to the flash drive Flash is not full duplex like some HDD's.
Link to comment
Share on other sites

Thanks RAM GUY

 

Well, the problem has been identified, but I'm not happy :(

 

I formatted the Corsair Voyager Mini 16GB FD with FAT32 and tried copying big files to it and accessing the drive at the same time, or files on my PC etc, and it was 100% fine!

 

Then I tried formatting the Corsair 16GB to NTFS with 4K Allocation units but it still had the same freezing problem.

 

Then I tried formatting another 4GB Flash Drive with NTFS and it ALSO exhibited the freezing problem.

 

So the problem is not the Corsair Flash Drive. It is simply NTFS filesystems on flashdrives in XP64.

Now if I can just solve this issue!

Link to comment
Share on other sites

Well, there are no windows updates with the keywords 'usb 64' or 'ntfs 64' or 'flash 64'

 

I wanted to make a truecrypt volume on the drive bigger than 4GB and still keep files on the FD that were unencrypted. This is not possible, with FAT32, and causes slow freezing issues with NTFS on XP64. so basically I decided I'll just encrypt the whole partition on the flash drive.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...