Jump to content
Corsair Community

Surely something can't be right?


AlienwareALX

Recommended Posts

I have an X32. I have had it for about three weeks now.

 

When I got it the max write in ATTO was 80mb. The max read was 199mb.

 

I ran ATTO today just for the hell of it and I am getting 25mb write and barely 80mb read. I booted from my raptor, wiped the drive with quick format and replaced my image using Acronis. Yet it still gives the same or worse results.

 

The thing is I have noticed no performance degradation AT ALL and Windows still boots just as fast as it did the day I installed the drive.

 

I ran Crystal and it also gives terrible results but I did get 40mb write and 110mb read. How could these vary so much and why am I getting less than half my score in ATTO in three weeks?

 

Now I did update the video and chipset drivers today, so that may have something to do with it? I also lowered my virtual memory settings, then disabled, then restored but that isn't changing anything either.

 

Does any one know how long this degradation of speeds is supposed to take? I also updated my bios today but not until after I had done serious testing.

 

What's odd is that Windows 7 still rates the drive as 7.1. So could it be that these benchmarking utilities are completely innacurate? I mean really, a read speed of 80mb would be less than my 74gb raptor which takes about 35 seconds longer to get into windows with everything loaded.

 

As I say, I have noticed no speed changes what so ever and windows is still taking the same ammount of time to boot and shut down. I have all of the Windows updates.

Link to comment
Share on other sites

Actually scrub that. Performance is far worse as I just watched a video I made of my PC booting the day I installed and set up the drive and it is indeed slower :(

 

Is there any way I can get this switched for a P series with TRIM? I reside in the UK. I paid a lot of money for this drive..

Link to comment
Share on other sites

Hi there :)

 

I found that utlity. Sadly it said my drive was locked. However, it did go on and erase the drive. Using a different way I suppose? It loaded a command type screen and took about 25 mins. Am just testing the drive with ATTO now and will report back very soon :)

 

EDIT. Okay I have now ran the test twice. Once with ATTO on my old raptor and once with it on the SSD.

 

The test from the raptor is as follows.

 

http://i72.photobucket.com/albums/i174/timmahtiburon/Untitled-4.jpg

 

And the test from running ATTO directly from the SSD

 

http://i72.photobucket.com/albums/i174/timmahtiburon/Untitled2.jpg

 

And the test I did on the first day of using the drive.

 

http://i72.photobucket.com/albums/i174/timmahtiburon/ATTObenchmark.jpg

 

Just to point out.. The Raptor has my install on it that was imaged to the X32 on the first day of owner ship.I have not updated the drivers or ran Windows update in this one. So basically I should get at least the performance in the final pic there. Write speed has never been what it should be tbh and I am beginning to suspect a faulty lump of memory on it or something :(

Link to comment
Share on other sites

http://ata.wiki.kernel.org/index.php/ATA_Secure_Erase

 

A possible solution for SATA drives is hot-(re)plug the data cable (this might crash your kernel). If hot-(re)pluging the SATA data cable crashes the kernel try letting the operating system fully boot up, then quickly hot-(re)plug both the SATA power and data cables.

 

It has been reported that hooking up the drive to an eSATA SIIG ExpressCard/54 with an eSATA enclosure will leave the drive security state to "not frozen".

 

Sorry. Absolutely no way I am doing that.

Link to comment
Share on other sites

Actually, I believe that is th ONLY way to get it to unfreeze. Hot plugging is part of the AHCI/SATA specification and afaik will not damage the system - you don't have to 'do it quickly' - just get Linux up and running, verify you can 'see' the disk, pull the power cable from the drive, wait a few secs, put it back on, wait a few secs, verify you can see the drive, and run hdparm. It should now be unfrozen and you can get on with the job. Has worked for me every time.
Link to comment
Share on other sites

OK I read an article written by a.n.other SSD drive owner. So I realised I was being a fanny. Right, I unfroze the drive and ran the command to secure erase. A message came up saying it'd take 30-60 mins or something but it seemed to be done in a few seconds.

 

I just formatted the drive.. here goes...

 

Well, as the saying goes in Yorkshire.

 

Well bugger me wi'd fish fork.

 

Yes.. Yes I would say that has definitely solved the problems I was having :laughing:

 

http://i72.photobucket.com/albums/i174/timmahtiburon/wow-1.jpg

Link to comment
Share on other sites

Try this one. It gives a locked drive message but it bypasses it in the erase process. I used it a couple of days ago and it worked fine.

 

I shall keep that in mind for next time, thanks :)

 

I can't believe the performance has started to degrade so quickly.. Mind you I have to admit that I have had an OCD and been running Disk cleanup every day.

 

I'm going to get myself another SSD soon. Just a cheapy I have seen with a 170mb max read for putting my games on.

 

I'm just glad that I have a formula for getting the peformance back tbh. I guess I was really worried at first about hot plugging the drive but I was being stupid because I forgot SATA is nothing like IDE.

Link to comment
Share on other sites

  • Corsair Employees
I can't believe the performance has started to degrade so quickly.. Mind you I have to admit that I have had an OCD and been running Disk cleanup every day
.

 

Running these utilities on an SSD may be the cause of the slow performance.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...