Jump to content
Corsair Community

No reply to emails - RMA 1140704Y


Ellis456

Recommended Posts

I am very annoyed, I got an email on the 29/12/09 to say you have my ram, that was fine, been checking everyday and my RMA status never changes!, I have emailed you 4 times to different addresses and no one will give the decency of a reply!!:mad:.

 

 

It has cost me £8 to post this ram to you and now have no ram that cost £60, this is technically theft.

 

 

I sent in the ram early as I have to move out at the end of January so was hoping I would have had the ram back by now or before the end of January hopefully, so now it'll properly turn up and I wont be here.

 

I am not ringing an international phone number, I do not pay the bill, I will never use corsair ram again, if my ram it faulty on return I will just bin it to save me the hassle. Very bad customer service.

 

My RMA number is 1140704Y, Your Support ticket has assigned Case #1263379.

 

Thankyou.

 

 

Thank you for choosing Corsair products! The following is the status of your RMA Number 1140704.

RMA Issued On: 12/20/2009

Defective Parts Received on: 12/29/2009

* NOTE: it may take up to 24 hours for this date to be updated after arrival at Corsair

Part Number Received: N/A

Quantity Received: N/A

RMA Replacement Parts Ship Date: N/A

Replacement Part Number: N/A

Replacement Part Quantity: N/A

Replacement Shipping Method: N/A

Replacement Shipping Tracking Number: N/A

Link to comment
Share on other sites

  • Corsair Employees
I am sorry we can no longer check RMA status in Tech Support; please call our customer service at 888-222-4346 or 510-657-8747 Ext “3” or send them an email (rmaservice@corsairmemory.com) with your RMA# and ask them for the status!

 

I have sent them a message and asked them to contact you but if you can it might be best to call in and talk to them.

Link to comment
Share on other sites

Oh no I spoke to soon, just tested with memtest and im getting errors again, not like last time though, before I would get thousands of errors on the start of the test the new errors come around at 20% of the first pass and around 56 errors, I have tried it with usb legacy on and off and still the same, even tried 2.2v as using 4 sticks at 1066.

 

What I cant get is I used all 4 for 6 months plus and at 2.2 and no errors at all. Do you think one or both the new sticks is faulty?, are these checked at corsair before being sent?, if otherwise will I need to rma again?.:(:

Link to comment
Share on other sites

  • Corsair Employees
using 4 sticks at 1066

What is the complete system configuration and have you test the modules one set at a time at their tested setting? And Legacy USB will have to be disabled if you use an ASUS MB.

 

With 4 modules I would suggest setting the memory frequency at DDR667 or DDR800 depending on the CPU and MB you use and set the memory Voltage to 2.1 Volts and set the NB/MCH/SPP Voltage to +.2 Volts as well and test the system with http://www.memtest.org. In addition, with some MB's (Mostly ASUS) you have to disable legacy USB in the bios when running any memory test.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...