Jump to content
Corsair Community

Flash Voyager 64 GB Not Working


Scottymacg5

Recommended Posts

Hello, I have been "Lurking" in these fourms for a while looking for a solution to my issue. It seems I have the same problem as many with the 16GB voyager drive. I had a 64GB Voyager that seemed corrupted, I tried all the solutions recomended (SD Format Utility) Etc... I actually returned it to the store of purchase (UNNAMED) They were kind enough to replace it with a new one (Same Model Voyager 64GB) however after 3 months, the same problem. I'm discourged by the fact that I have lost a nice chunk of data, for the second time. (I have a more or less recent backup) but still the purpose of a flash drive is reliable , portable data. Is there any other utilities I may try to:

A. Recover the partition or Volume info on this

B. Re-Format with more Stability or reliability?

C. Protect my $$$ Purchase from Corsair...

 

Please note my profile has system specs as All Macintosh, But I also havea 32bit XP PRO system as well as 64Bit Windows 7 Ultimate, The 64GB Voyager does not show on either. In windows , the machines recognise the drive but cannot format or read any volume, In MAC the disc Utility dose not pick up anything pertaining to this drive.

 

Any help or suggestions would be much appreciated.

Link to comment
Share on other sites

I tried the suggested tool, but the 64 GB Drive does not show in the drop down. When inserted the system shows the (Safely remove drive) in lower system tray, but the volume does not get detected by the system . Weird that it shows in Disk manager, but cannot be formated or changed at all.

Can it be sent in for diagnostics or repair?

Link to comment
Share on other sites

There is no hope for this drive. I've tried all the utilities, but this is whats happening:

The drive used to always mount as "VOYAGER", now when inserter it mounts as: Removable Drive (E:), I get absolutly NO LED light action on the drive itself. Then a popup says "Please insert a disk in Removable Drive (E:)

 

I think its finished, and the fact is it has not so much as even been dropped.

I started the RMA process but not heard back anything. I just keep checking this fourm.

 

Thanks

 

HAPPY NEW YEAR TO YOU ALL

Link to comment
Share on other sites

  • 2 years later...

I know this is a lot later, but my replacement 64GB voyager is dead & has been for over 6 months. I just got around to finding this thread. What is my recourse with this product? The replacement that was sent is a "Yellow & Black" Flash Voyager GTR drive, Upon insertion it just Blinks Blue and is not picked up by ANY system.

 

I hate to be a complainer, but this drive wasn't cheep, I could have bought a TB Hard disk, less portable but more reliable.

 

Can you send me info og getting this one replaced?

 

Original was purchased at Microcenter, this one came straight from Corsair (As a replacement)

Thanks

~ScottyMac

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...