Jump to content
Corsair Community

Corsair x64 / Adaptec 5805 compatibility issue


scy

Recommended Posts

I just tried to upgrade my system with four Corsair x64(CMFSSD-64D1) SSD's, but with little luck....

 

when the drives are connected to the onboard controller of my ASUS Striker II Extreme they work fine, but running them on the onboard controller is simply no option.

 

now, when i connect the ssd's to the adaptec 5805 everything seems fine until the first access to the disk or array occures:

the controller starts beeping, system freezes... (ok, sometimes it takes 10-20 sec before it starts to beep and freeze)

on the next start the controller reports a failed disk - no, not always the same disk... totally random.

i've tried all stripe sizes, read/write caches on/off, even single disks - it's always the same outcome : first access --> beeping controller, drive(s) missing, system freezing

 

the controller and cables are definitely not the broken, since my old raptor and savvio array's are working perfectly.

controller firmware tested: 17517, 17544.

 

i ran a disk verify with the adaptec utility which showed no errors....

 

before purchasing the drives i read the forum to see if any of you had problems with a similar setup, and ran into a post of RAMGUY saying:

"We have not tested that specific Card but I do not see any reason there would be any issues with any SATA/SATA2 Raid card on the market."

which made sense to me, since i never had issues runnig drives that do not show up on adaptec's very limited compatibility chart....

 

thx for any suggestions to get this solved.

Link to comment
Share on other sites

I notice that your board is running an Nvidia Chipset .... these have been known to cause numerous problems (all differing) for SSD users. I would imagine that you have already update to the latest versions of the drivers (if not then I would recommend you check to see if there are any updates). To eliminate the possibility of the drives being dodgy, can you try them in another system and see what happens; I know this is not always possible, but if you can it would help.

 

Because the problems with the Nvidia chipsets are numerous I would suggest you Google for the problem and see if anyone else has come across this problem and what, if any, solutions they found. Again, I know it's a nuisance, but because these problems are varied it's difficult to give a definitive answer.

Link to comment
Share on other sites

Thx for your reply Davyc,

but I'm not using the onboard nvidia controller for the corsair ssd's.

in fact when i'm doing so (using the nvidia sata) everything works, except it is not as fast as i would expect it to be. that's not what i'm buying ssd's for ;-)

 

the problem is the adaptec controller in conjunction with the x64 drives...

 

drives and controller on their own work fine.

 

and yes, drivers are up to date - even tried downgrading to different firmware and drivers, removed all other unnecessaryhardware from the mb....

 

i'm really out of ideas here....

Link to comment
Share on other sites

all i want to say with this is that the drives do work on the onboard controller, but in a productive environment i don't want them on this controller.

 

as davyc correctly stated, that SATA chipset on my board has some serious issues in regard to reliability (not only in conjunction with ssd's). my old raptor array was failing every 10th boot, so i had the board repaced, but no change.

so i bought the adaptec controller, reinstalled the system and everything was fine for about 6 months, until that SSD idea crossed my mind.....

 

once again: i can run the drives on the onboard nvidia raid controller, but performance and reliability s***, so I've decided to regard the onboard SATA as broken by design !

 

hope the confusing part is solved....;)

Link to comment
Share on other sites

ok, now the drives aren't even working on the onboard controller anymore.

just dissolved the array and tried single disks, but half way through th win7 setup the computer freezes. (tried two different drives, same outcome)

 

is it possible that the corsair ssd's only work with intel sata controllers ?

 

just wondering because they only work when they are connected to one of my intel based boards.

if so, somebody should put a big sticker on the box.......!

Link to comment
Share on other sites

Intel chipsets have been causing more trouble due to a mixup with the Matrix RAID drivers suprisingly. One of the latest versions would actually send the TRIM command to the SSDs and would cause them to hang up since the drives could not recognize the command.

 

I've had my P-series work on my AMD 780G/SB700 setup without problems, as well as Intel's PM45 chipset without too much problems. However, that was with a single drive only.

 

It sounds like RMA would be the next step for you.

Link to comment
Share on other sites

It sounds like RMA would be the next step for you.

 

All four (4) of them ?

I really don't think the drives are broken....

...keep in mind they do work on intel chipsets.

 

btw-

just got a bunch of ssd's from a different manufacturer (with indilinx contr.) - same story :mad:

 

after reading a little bit in some other forums i really get the impression that it might have something to do with the indilinx barefoot controller of the drives... adaptec and indilinx seem to have "issues"...

 

but adaptec is working on a solution....

"Currently we are working with a number of SSD drive manufacturers to resolve compatibility issues and be able to add more models of SSD drives to our compatibility report."

- but when :confused: ?

Link to comment
Share on other sites

  • Corsair Employees
I would search for Gparted in the SSD section and then look for parted magic and run the software with the drives set as single drives in IDE mode and under system tools run the Erase Disk tool and try wiping the drives.
Link to comment
Share on other sites

OK, tried that, but as expected it won't change the behavior of the problem....

 

when booting from the gparted cd everything is fine until i start the partition management tool and the drives are accessed for the first time: controller starts beeping, drives vanish from the selection menu....

 

i don't think that this issue can be solved by changing settings.... waiting for the next firmware from adaptec.

 

but thanks for the input

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...