Jump to content
Corsair Community

Possible bad install of H50


cjm187

Recommended Posts

My H50 came in today and I may have screwed it up. My temps are higher than with the zalman 9700. First I noticed that it didnt screw down all the way, it was secure but it couldnt tighten. The back plate was tight tho for 3 out of 4 screws. From all looks of it, it was seated properly, tho I did originally have to lift the bracket to be able to turn the cooler in place. The reason I think it wasnt tightened all the way is because of the thick sticky pads, maybe I should take em out?

 

I ordered 3 case fans which should be here fri to maybe help for exhaust? Im not too concerned the temp difference is only a couple degrees idle im hitting about 45 idle with a 3.6 oc of the 920. What scared me tho was just 2 mins of prime 95 i was up to 96, no blue screen but I quit out, gaming I didnt go over 60 so I will see Fri if the fans help at all.

 

If you guys think I should reseat it should I take off all the thermal paste? Also should I take off the sticky pads, they seem awfully thick.

 

 

Thanks

Link to comment
Share on other sites

Ouch yup that is pretty Tosty..

1. As far as the pads i took them out, they kept plate too high up.

2. Make sure when u put Retaining Ring on to the back plate you only tightened up the screws by 3-4 turns. Then put the water block on even and try not to push the thermo compound around to much, the only movement on the block should be when you turn it.

3. Make sure that teeth in the ring sit tight and flush with the grooves, make sure the screws are nice and tight, also try to tighten them in a X pattern.

4. Make sure you have lots air flow going across the radiator, i have the stock fan at the exaust sucking in cold air from back then a fan on the fron for a push/pull type fan set up.

5. Also what is your Voltage at on the CPU?

 

Can you take a pic of your set up?

Link to comment
Share on other sites

Ok it was a bad install hehe.

 

I had the backplate screw hole thingys in side ways doh! Reseated re thermal pasted and my idles are at below 40! so im pretty sure that solves it I hope i didnt do any permanent damage tho.

 

Just an edit running prime 95 for a few mins and temps are at 63-67 so that is a HUGE upgrade lol and my cpu voltage was 1.224 btw

 

 

Oh and the fan logo is on the inside right thats how it was in the video. Just making sure I did that part right, and if i put an additional fan which way would it go.

Link to comment
Share on other sites

Oh thats great! Yeah the back plate is a lil wierd u acually have to make it crooked to make it straight haha. Yeah getting up in the 90s is bad, but i doubt perm damage. I have a i7 860 and i dont think ive toped 68c running prime 95. This cooler is amazing. Last night when i was web browsing i hit 18c hehe
Link to comment
Share on other sites

Just making sure, because 4 fans are comin tomorrow. I have the corsair logo pointing to the inside in front of the radiator and the one i mount the logo will be pointing towards the radiator on the other side? Also for the 3 fans I mount to the top all the logos should be pointing up right?

 

Sorry for my dumbness

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...