Jump to content
Corsair Community

X256 'disappears' when win 7 64 restarts


Cadencia

Recommended Posts

A couple of days ago I 'upgraded' from Vista 64 Ultimate to Win7 64 Ultimate. The process involves several automatic restarts. At some point, the system froze. Pressing the reset key on the computer an the POST checks - and the SSD was not detected. Power off and immediate power on restored the device. And the install continued happily. Until the next automatic restart when the same thing happened, requiring again the power off/on sequence.

 

Finally, after fixing the apparently mandatory series of BSODs caused by various drivers being no longer valid, the system is stable and no slower than previously under Vista. But I am still finding that the SSD will only work through one single power cycle.

 

When I shutdown the computer, it freezes before turning off the system power - but not until the proper stuff has been written to the SSD (at least, on restarting windows doesn't complain about not having been properly shut down). If I 'Restart' the computer, it freezes exactly the same. And, again, the reset button starts the POST checks, and finds no SSD. Power off/on restores it.

 

I am guessing the Win7 causes the problem, because I didn't notice Vista acting this way. But the SSD is new (measure age in days rather than weeks) and I may just not have noticed it.

 

The SSD is attached to the gigabyte sata controller (Jmicron, I think), configured as a RAID controller, with one drive. Done this way to facilitate Acronis clone from previous Velociraptor stripe raid.

 

Apologies for the garbled explanations. I am reporting here hoping that the problem is not unique so a fix may be found somewhere.

 

I'm happy to do tests, btw. I know my backup system works properly!

Link to comment
Share on other sites

Yes, Ram Guy, I could move to another controller, but not without reformatting the SSD and completely re-installing - the device is configured as part of a RAID, so a different controller would need to make it's own mark on the disk.

 

So, I won't do that just yet, but thanks for the response.

 

But, one time, it shut down properly! So I have started keeping rudimentary records. So far, I have had two successful shutdowns, four failed shutdowns and one successful restart.

 

At that point I found there was a deficiency in the BIOS that made Virtual PC think another virtualization system was running, so I updated to the latest BIOS.

 

Since then I have had one successful shutdown - and I'm writing this and planning to do a day's work before further shutdowns.

 

I will report back in a day or so.

Link to comment
Share on other sites

  • Corsair Employees

You stated that it was just using the Raid controller not as part of a RAID array?

The SSD is attached to the gigabyte sata controller (Jmicron, I think), configured as a RAID controller, with one drive. Done this way to facilitate Acronis clone from previous Velociraptor stripe raid.
Link to comment
Share on other sites

Yes, Ram Guy. It is attached to the controller which is configured as a RAID. The particular controller allows devices to be added as striped, mirrored, or JBOD, but not as "just disk". So, as far as Windows is concerned it is a RAID, using the RAID driver. It sees the SSD as a SCSI device.

 

I originally had a pair of Velociraptors in a stripe raid configuration, and when converting my Vista 64 system to the SSD, I used Acronis to make a disk image, and restored that to the SSD. I did try to reconfigure the controller to an AHCI device, and it worked OK - but Windows would not boot, because it expected a RAID for the system disk. Catch 22.

 

So - it is one SSD disk added to the controller as a JBOD. The hoops we jump through!

 

Whilst it was running Vista, there were no problems. During the 'upgrade' it started disappearing, as described. After the upgrade was finished it continued to misbehave.

 

I think all this may be academic, however, because since upgrading the BIOS from F5 to F7 I have had NO problems. Whereas yesterday, up to new BIOS I had six failures and two successful shutdowns, and no successful restarts, since new BIOS I have today had two successful shutdowns, three successful restarts, and three successful restarts from pressing the reset button (system froze trying to remove no-longer-valid drivers).

 

From the beginning, the SSD has worked flawlessly except for this disappearing trick.

 

If anything changes I shall re-post.

Link to comment
Share on other sites

I stopped counting restarts etc after 20 successive successes. The whole experience of Win7 and the X256 is far superior to Vista and Velociraptor. Startup used to take five minutes from pressing the power button to when it got itself sorted out and I could do anything serious. Now it's between one and two minutes. Even less if I hibernate rather than shutdown. Hibernate under Vista would give BSOD more than half the time on restart. Now - perfect so far.

 

I was always ambivalent about the superfetch thing - tried it both ways. If it could have been limited to a gig's worth or so it might have been good, but dragging in an 6G cache in advance of requirement?? Anyway, with the SSD and having turned it off - super responsive, and no continuous disk seek noise.

 

The only thing troubling me now is trying to get a handle on the likely future performance issues as the drive gets more 'used'. I started another thread asking about that stuff, but it seems to inflame rather than get definitative answers. http://forum.corsair.com/v3/showthread.php?t=82910. Each answer seems to raise another question. I suppose the folk who can really provide the answers are in Korea somewhere.

 

I feel a bit like the joker who fell off the roof of a skyscraper and muttered to himself as he passed each floor on the way down, "so far, so good".

 

It IS good, though.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...