Jump to content
Corsair Community

Corsair Survivor 16GB Slow Detection in Windows 7


jhonny206

Recommended Posts

Hi,

I just bought today a USB Flash Stick Corsair Survivor CMFUSBSRVR-16GB.

 

After the first time use when the driver's were first installed I unplugged the drive.

Then I plug the drive in.

A blue light on the usb stick appears and it stays 1.50-2 minutes.

I can see the drive listed in windows explorer.

I try to access the drive (to list its contents) and the windows explorer and it simply shows me the "wait" cursor for about 1.5-2 minutes before I can access the drive's files.

This happens EVERY time I plug in the USB Stick.

 

A few more details:

-The Slow Detection happens in my current O.S: Windows 7 Enterprise 6.1.7600 32Bit.

-The Slow Detection doesn't happen on the same computer in Windows Vista Business 32Bit.

-I've tried another usb-stick from another manufacturer on same computer, Windows 7 Enterprise and the Slow Detection doesn't happen.

-The Corsair Drive doesn't have speed issues for reading/writing after I can access it. It has ~31-32MB/s Read 10.0-10.7 MB/s Write reported by Total Commander on a 700MB avi file copy.

 

I've noticed that I'm not the only one on the forum with this problem. There are a few others that complain about their Flash Voyager Slow Detection in Windows 7. So please enlighten us if you can :)

 

My thoughts:

This looks to me like a Driver Issue since the Slow Detection doesn't happen on the same computer in Windows Vista.

I will try to install windows 7 on another machine and see if the same behavior occurs.

 

What I would like to know is:

1) Did Corsair test their Survivor USB Flash Stick on Windows 7 Enterprise 6.1.7600 32Bit? Did the Slow Detection issue ever occur? Any other known issues that I should be aware of?

 

2)Which driver do you think is the problem? Motherboard's? Corsairs USB Flash Stick Driver? Some other driver? Some other problem?

 

3)Any thoughts on how I can fix this annoying problem? (waiting 2 minutes before you can access the drive is not acceptable).

Thanks for your time.

Link to comment
Share on other sites

  • Corsair Employees
Moved your post to the correct section, this is most likely a Windows 7 update, I would keep checking with Microsoft for the latest drivers for the MB and or chipset as that would be the most likely solution, I would also suggest you try and format the drive with the SD-CARD Organization. Format utility, but please noe you may have to use this in a system with XP or Vista I have not ran it in a system running Windows 7.
Link to comment
Share on other sites

The drive doesn't work properly regardless of the file system. I use Fat32 anyway. I tried SD Card Formatter, that didn't help either. This lead me to think it's not a file system issue.

I've tried installing Windows 7 Ultimate 64bit and a Windows 7 Enterprise 64Bit on other computers and the drive doesn't have any issues. As you've said the most probable cause are the motherboard drivers for windows 7.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...