Jump to content
Corsair Community

P256 experience with Mac Book Pro


Recommended Posts

I think I finally have a stable system using the P256 on my Mac Book Pro Core 2 Duo system (MBP2,2). The experience was not hassle free but now that I have a system up and running I will be very happy with the purchase as long as the system remains stable. I do fear the spinning color wheel of death cropping up in the near future, but so far so good.


I purchased the drive from NewEgg and it arrived promptly and I was like a boy on Christmas morning when it arrived. My first attempt to use the drive was to place it in a BlacX USB/E-SATA external cradle attached to the mac over the e-sata connection. The E-sata connection was provided by a eSTA Express Card and I have had no issues using this with other HDDs. I used Disk Utility to format the drive and all seemed well and quite snappy until the end of the format. The access light on the drive access dock remained lit and disk utility hung on an io wait and could not even be terminated with 'force quit'. After a forced reboot (power cycle) I tried the processes again with the cradle using the USB connection and had the same results. I then tried the drive in a different USB cradle (EZ-dock) on a linux box and I was able to format the drive, but it seemed to take forever and disk I/O was really show after the drive was formatted. But encouraged by this and thinking the drive performance may be related to the USB dock, I decided to go ahead and install the drive in the MBP.


Once installed in the MBP I was able to format the drive and start an install of Snow Leopard. But the install took a very long time, something like 2 hours. And often the progress bar would stall for long periods of time. After the install was finished, I was able to do the initial boot and things seemed very snappy, but as soon as I tried to use the drive with large files the system would hang, for example the shell command:


dd if=/dev/zero of=blank bs=1024 count=10000000


would zip along for the first few gigs and then hang (this command writes a 10GB file of zeros).


I RMA'd the drive and got a replacement the next week. Again I tried the USB/E-sata dock with the e-stat connection and had the same issue as before. The format would hang at the end (with the progress preciously close to the end). I then tried the dock using the USB connection and found joy with the disk format. It was a good sign. Instead of a fresh install of snow leopard I decided to try to use Carbon Copy Cloner to clone my Leopard system disk and I was able to do this. It took some time, about 4 hours to clone a 100Gigs of space. As the copy job was running, I did not see an signs of hangs so I was encouraged enough to install the disk in my MPB (a real pain for this model of Mac Book). The system booted and is running normally and I do not see any hangs with large file reads/writes. With the command:


dd if=/dev/zero of=blank bs=1024 count=10000000

I see disk write speeds of about 65 MB/sec in the activity monitor and the access speed is consistent. With the command:


dd if=blank of=/dev/null bs=1024 count=10000000

I see disk read speeds of about 120 MB/sec


The sata speed in my MPB is 1.5Gb/sec (roughly 190 MB/sec w/o overhead), so I think 120 is pretty near the limit of the sata interface.


I am just starting to use the system for day to day work and so far it is great. I am a little concerned that the drive did not work with the e-sata connection with the dock, certainly it tells me that the SSD is not a drop in equivalent of a HDD. I sure hope the system is stable -- I'll make sure the time machine backups are running! I really don't want to deal with another RMA.


Here are xbench results for my system before and after the drive change:


Stock HDD

Disk Test 28.55

Sequential 38.29

Uncached Write 37.02 22.73 MB/sec [4K blocks]

Uncached Write 35.73 20.22 MB/sec [256K blocks]

Uncached Read 37.86 11.08 MB/sec [4K blocks]

Uncached Read 43.35 21.79 MB/sec [256K blocks]

Random 22.76

Uncached Write 8.07 0.85 MB/sec [4K blocks]

Uncached Write 52.51 16.81 MB/sec [256K blocks]

Uncached Read 55.72 0.39 MB/sec [4K blocks]

Uncached Read 67.17 12.46 MB/sec [256K blocks]


P256 SDD (Installed)

Disk Test 173.31

Sequential 137.48

Uncached Write 198.62 121.95 MB/sec [4K blocks]

Uncached Write 165.77 93.79 MB/sec [256K blocks]

Uncached Read 74.29 21.74 MB/sec [4K blocks]

Uncached Read 218.94 110.04 MB/sec [256K blocks]

Random 234.39

Uncached Write 100.62 10.65 MB/sec [4K blocks]

Uncached Write 250.34 80.14 MB/sec [256K blocks]

Uncached Read 1476.36 10.46 MB/sec [4K blocks]

Uncached Read 407.27 75.57 MB/sec [256K blocks]


P256 SSD (USB/E-SATA dock w/ USB connection)

Disk Test 42.67

Sequential 28.02

Uncached Write 31.71 19.47 MB/sec [4K blocks]

Uncached Write 32.92 18.63 MB/sec [256K blocks]

Uncached Read 17.69 5.18 MB/sec [4K blocks]

Uncached Read 41.16 20.68 MB/sec [256K blocks]

Random 89.41

Uncached Write 56.77 6.01 MB/sec [4K blocks]

Uncached Write 59.62 19.09 MB/sec [256K blocks]

Uncached Read 735.49 5.21 MB/sec [4K blocks]

Uncached Read 111.19 20.63 MB/sec [256K blocks]

Link to comment
Share on other sites

  • Corsair Employees
I would expect from the results and what you stated the controller is working at S-ATA1 mode and if so you may not get better than that and the E-Sata port is hard to speculate but I would suggest talking to Apple. AS it sounds more like a firmware or driver issue with that device.
Link to comment
Share on other sites

Yes, my internal sata is sata 1 at 1.5 GB/s (it's one of the first core 2 macs from 3 years ago) and I am satisfied with the performance. I just took a look at a new Mac Air with the built in SSD and it is not as fast (for sequential read/write) and that make me happy.


As for the e-sata issue, it is really for your information -- with three hardware manufactures in the loop (computer, esata card, disk dock) I'm sure fingers will pointing from each manufacturer to the each other. All I can say is that I've used many drives with the esata dock with no problem.

Link to comment
Share on other sites

  • Corsair Employees
I am not pointing a finger really other than the type of error would suggest a driver or firmware issue with the controller being used and for sure I would check with the manufacturer more for any updates and see if they have any known issues with that using any SSD, I have not had any other reports of any problems using the E-Sata ports on any system with any of our SSD's.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...