Jump to content
Corsair Community

performance drop on 2x p128 in raid 0


robinlawrie

Recommended Posts

ok, bit of a long post.

 

i have 2x p128's in raid 0 (intel raid controller)on the a gigabyte ga-ex58-ud5

these are used as my system drive and backed up on a 1tb hdd.

i have windows 7 rc x64

 

due to win7 not installing properly on sata raid arrays (is this fixed in the released version?) i had to install on one drive then migrate to the other drive using matrix storage manager.. this worked perfectly.

 

when i first installed i was getting hdtach scores in the high 400's (not a suitable benchmark i know, but..)

 

yesterday i think i knocked the sata cable to one drive whilst it was running. this completely killed the raid volume, and i had to re-install..

due (i assume) to the raid problem with win 7 installs, my disk image of win7 wouldnt reinstall, whatever i tried.

 

i re installed using one drive, then tried to migrate to the other drive. i got an error saying that the drive i was trying to expand onto was smaller. i tried EVERYTHING i could think of.. finally i found out about hdderase, and ran it on the empty ssd.

 

the raid array then migrated fine, and im back up and running. (128kb stripe)

 

HOWEVER.. my windows experience score was lower, so i ran hdtach again, and im now only getting average hdtach read speeds of 230 mb/sec..

 

this is close to a single drive so what the hell is up and how can i fix it?

 

please heelp i use this drive for hd editing also so the performance really matters.

Link to comment
Share on other sites

crystal disk mark scores for the current setup:

 

357.8_215.2

270.3_153.5

25.48_9.493

 

do those scores look normal for a dual p128 raid setup? i didnt run it before the catastophe you see.

 

the 4kb random reads and writes look terrible to me? i know its a weak spot of ssd's but still... 9mb/sec?!?

Link to comment
Share on other sites

You should be able to install the Raid aray driver durring the install of Windows 7 by using the F6 Key when the setup first starts. If this si not working or the driver is not working you may need to get an updated BIOS or driver from the MB Maker.

I would try and copy the image using Accronics Drive image and the use the Gparted method to delete the partition and whipe it. Then recreate it with 128K Clusters in the Rad and 32K Allocation for the format and test the drive before you load the O.S.

Link to comment
Share on other sites

I had the same problem trying to install my image on a RAID 0 with two P128s,using an Acronis 2009 boot disk. The problem was solved when I download the multiparameter boot disk from the Acronis web site..it apparently can recognize the RAID 0 with two SSDs. I use Win 7 Pro and haven't seen a performance drop I can notice,but within hours the Windows experience score dropped from 7.3 to 5.9. Had a problem installing the Win 7 on this array as well,until I removed each drive and "pre-formatted " them,after that Win 7 could see the array
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...