Jump to content
Corsair Community

Those little metal screw end things


DomLof

Recommended Posts

Hi all!

 

So I've just installed the H50 and I managed to pick the wrong screw (well they are very similar) and as I forced the screw into the little metal case thing I managed to split it.

 

I did find out that the screw was wrong AFTER I did this and managed to get it right for the rest of them.

 

But this means I've now got an almost broken tiny metal screw end (it just about works I think).

 

I've had to dismantle the cooler as the mobo died on me, and now I'm wondering where I can get one of these tiny things from?

 

I'm in the UK by the way ...

 

Dom

Link to comment
Share on other sites

No,I think he means one of these?

 

 

 

http://img11.imageshack.us/img11/8040/h50c.jpg

 

Yes exactly! :biggrin:

 

I've attached a pic of the mangled item.

 

Any idea where I can get hold of another?

 

Or is there an alternative screw/bolt that I can use?

 

Thanks

 

Dom

1786662408_photo2.thumb.jpg.2a097e64be910e06b8d623b4c2bbc31b.jpg

Link to comment
Share on other sites

Wow!:bigeyes:You know your not supposed to force anything on a delicate computer.:roll:

 

Yes I know, but I've been in this game long enough to not have patience any more! And I've always found coolers the worse things to connect up.

 

Funny as this cooler was actually pretty easy to connect up, once I used the correct screw ....

 

So is there any hope for me? :(:

 

Dom

Link to comment
Share on other sites

  • 2 weeks later...

I also need what you need as well as one screw and a new back plate. I stripped the plastic brace where the mounting insert goes on the back plate (the 1366 insert) because one of the screws' threads were "off" and didn't turn easily so I had to turn the screw hard and subsequently stripped the mounting insert hole on the back plate (the mounting insert metal piece "nut" if you will) kept turning in the insert (the 1366 hole) and stripped it. I then had to remove the mobo to clamp on a pair of vice-grips on the mounting insert "nut" to keep it from turning so I could tighten the bad screw on metal the CPU bracket. It's about 80% tight...the other three are 100%. Two thoughts, 1.) QC should be made on all screws and mounting inserts maybe I was just the unfortunate one and 2.) maybe the back plate should be metal. Mixing metal and plastic in assembly components usually doesn't work 100% of the time...metal with metal would be best. I emailed tech support express about 10 days ago about my plight and needing the three new parts and I have not heard back from them yet. Let me know if you hear back from them on how to get replacement parts, I don't want to RMA the whole H50 for three parts. I'll do the same. Thanks!

 

BTW, the H50 is unbelievably cool (literally and figuratively). Average ambient temp 70F, case average temp 75F, idle CPU 19C, full 38C, idle average cores 33C, full average cores 42C, VREG idle 44C, full 48C, GPU idle 41C, full 58C, have the H50 fan blowing into the case, I have other fans with blowing in/out/on configurations...total fans including PSU and H50 = 10 excluding the GPU fan which by far blows the hottest air out of the case. No OC, all default BIOS settings.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...