Jump to content
Corsair Community

SSD doesn't show in BIOS?


Recommended Posts

Hey hey,


I just bought a new PC, specs is what is listed on my profile, and for that i bought the Corsair Extreme 64gb for an OS disk, when I tried to install my Windows 7 it didn't show up as one of the drives I could install on, then i tried to check the BIOS to see if it was listed there, it wasn't. I have tried to change the SATA cables(and ports) plus the powercable with no luck. I have also tried changing the setting in the BIOS from IDE to ACHI, no luck there either.

I can see my other HDD and my DVD drive both in BIOS and when installing W7.



I really am lost on this one, any help would be much appreciated :)



~ Jens

Link to comment
Share on other sites

Well I have bought it the place I work here in Denmark, and they have their own RMA department that handles these kinds of things, so I will just take it with me tomorrow and see how it goes :)


Many thanks for the quick reply, greatly appreciate the good service :)

Link to comment
Share on other sites

I've the same problem as the OP with the x64. I've done the same things as him, tried switching SATA ports and cables and unplugging everything but the SSD. I've even tried on another (new) computer and motherboard but it still doesn't show up in BIOS.


So is it an error casued by the manufactorer?




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...