Jump to content
Corsair Community

Brand new Corsair X64 broken???


Recommended Posts

Hi

Have tried all day now to install windows 7 or windows XP to my newly bought corsair X64. The first I tried was to install windows 7 on it but the disk could not be partitioned. I then booted my old winXP system and there I could partition it but when I tried to format it is says it is unsuccesful. I have also tried GParted and it partitions and formats without complains but when I try to install again windows copies files for a while but then complains that they are unreadable. Back in my old winXP it now says the disk is corrupt and unreadable.

 

Are there any software tools to check if the disk is really broken? I hate sending things back, it´s a real pain in the b*tt.

Link to comment
Share on other sites

  • 1 month later...

Hi again

After a month I got a new disc. The first I did was to try to install win 7 again but same error as last time. Back into win XP again I tried to formate it and Lord and behold, it succeded and I could save a small video clip to it and view it. Yes, its working at least I thought.

Having formated it I now tried again to install win 7 but same error. It copied files for a long time and then said they are all unreadable. Back in win XP again the drive now fails to formate. I have tried Partition Wizard and it can partition the disc (made two partitions) but when I try to formate one of them it all freaks out and the whole disc is back to unallocated. I tried HDDerase but the program hangs when it should show my discs, cant get it to work. I am using the same cables that I have to another sata disc (old fashion rotating disc..) so I have trouble believing it some fault with my computer, although what are the chance that two sdd discs should have the same problem???

I don't know what to do. Send it back again? They will probably start to ask what I do with the discs...

 

EDIT: Solved (kinda)

Ok, I was wanting to test the ssd in another computer but my other stationary didn't have any sata-ports at all. Then I wondered what kind of disc it was in my newly bought laptop, Acer Aspire 3810TZ, and it was an 2.5" sata drive. So I exchanged that drive for my ssd and put my Win 7 on a USB stick which I made bootable and then I installed win 7 on the ssd without any problem! However, when I put the ssd back in my stationary it complained about hardware change (obviously) and couldn't repair it.

So, it seems my stationary computer can't handle ssd discs... It's an HP Pavilion d4495 with bios version 3.48. There are no upgrades for that so I am stuck. Seems the ssd isn't fully compatible with an ordinary rotary sata disc. Well, I'll keep this disc until I decide to upgrade any of my stationaries with new motherboard.

Link to comment
Share on other sites

You don't have your specs posted but from reading I'm guessing you're trying to install this on your HP Pavilion yes?

 

Stock BIOS from OEMs are known for only basic functionality, but you should be able to enable features such as ACHI. Some boards/chipsets are picky about that setting.

 

Also - something I ran into with my ASUS Laptop. On the exit page of the BIOS there might be two options - Load Manufacturer Defaults and Load User Defaults. If you see that, I would recommend hitting Load User Defaults and save settings.

 

Something to keep in mind as well - unplug all your SATA cables and put the SSD on SATA port #1 and plug in optical drives starting from the last SATA port. Try just having the SSD in there at first as you can go back to add a regular HDD later on.

Link to comment
Share on other sites

  • 2 months later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...