Jump to content
Corsair Community

HX850W buzzing


SnoopyTRB

Recommended Posts

Hello,

 

I have an issue that I'm looking for some suggestions about. I just built an i7 system with the specs in my profile. I am powering it with an 850HX which when under load buzzs quite loud. I'm wondering what you guys think about this.

 

Is the PSU faulty? Am I over taxing it which is causing it to buzz? Is it even possible for the PSU to buzz because it's being worked too hard?

 

I did try the speedstep disable trick in the sticky on the forums and it made zero difference. I originally had my system plugged into a surge suppressor but since I noticed the buzzing I plugged it straight into the wall. The buzzing did not change, it's just as bad as before.

 

Is it possible the PSU is still "breaking in"? I don't really want to RMA my PSU due to all the crazy cable routing I did, but I also don't want to risk $1500 worth of other parts on a fault PSU.

 

Halp?

Link to comment
Share on other sites

Are we talking GPU load here? If so, typical problem with the GTX cards. Try enabling v-sync. If the problem still exists, you can try RMA'ing the PSU. You can disconnect the PSU from its modular cables, leaving them in place, and just send in the PSU.
Link to comment
Share on other sites

Yes, it seems to be under GPU load. First noticed it running 3DMark Vantage. Also noticed it running Operation Flashpoint 2.

 

However it seems in the last hour or so the buzzing has gone away, even when I fire the games back up. Maybe just the PSU being brand new? :confused:

I will test the computer more tomorrow and post an update.

Link to comment
Share on other sites

Sometimes issues like this disappear during the burn in. The noise was most likely a coil touching something inside the PSU, and its vibration casuing the buzz, and once it has heated up its probably shifted enough to no longer touch the other object.
Link to comment
Share on other sites

So i let the computer run overnight and the buzzing was still gone when I got up. Today was overclocking day so I did that and the computer is stable but the buzzing is back. Really strange. I'm going to give it another day and see what it does. Hopefully it will go away again.
Link to comment
Share on other sites

weeeeeell. Tried all the suggestions in the stickies with power management and speed step. Tried Vsync in games. Even went as far as to try different video cards on the off chance the problem was a interference issue with the GTX 275's. I tried a single GTX 275, a 8800GT, and a 7950GT and the PSU makes the same electrical buzzing with all of them.

 

At this point the biggest thing I care about is whether or not my computer is in any danger. My voltages all look rock solid in e-leet and the computer itself runs great, it just sounds like an angry cicada when I make it work.

 

What do you folks think? Is going through an RMA worth my trouble? I don't want this computer to be down at all and I'm not sure how Corsair works their RMA's.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...