Jump to content
Corsair Community

Is the RMA status page sometimes slow to update?


C17chief

Recommended Posts

Just wondering since I show an RMA delivered and signed for 3 days ago but the status still says waiting for defective parts. If the status page just doesnt get updated sometimes, or if things are busy and waiting en que, thats perfectly fine with me as long everything is going through the usual motions. I'm just anxious to get my PC put back together and off the laptop, and just looking for a little re-assurance that everything is still in motion and not forgotten about or misplaced I guess :D: . RMA # is 1125114 if one of you Corsair guys can take a peek real quick.

 

 

Anyhow, my story is with my TX750 I got the random shutoffs untill a short time later it would only power up for half a second at a time at any attempt. Same wired up to another system, psu from other system powered up the original system, and psu bare with jumper wire test + 1 120mm fan on a molex same too with the half second and done. Unfortunate as it is probably the nicest PSU I have had over building my own machines since the 386SX-16 days (have had several prior to that going back to the old TI99 in the very early 80's before building my own). Random failures happen to the best of electronics, so no biggy. I look forward to getting my machine back together though. :D:

Link to comment
Share on other sites

Turns out to be just the status page. It had already been processed with tracking number and was waiting to be picked up a day before that original post was made, and was on its way the next day. It was already half way here when I emailed them and got a response next day.

 

 

 

Anyhow, new one has been in the machine for a couple days now running like a champ. :sunglasse

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...