Jump to content
Corsair Community

Voyager 32GB dead on a Mac?


Djeimz

Recommended Posts

I bought a Voyager 32GB from Amazon around September 2008, and used in heavily with an Intel iMac, OS X v10.5. Now it's unusable.

 

A few months ago it started unmounting itself when I wasn't looking. More recently it wouldn't mount at all. I rebuilt the directory with DiscWarrior, which worked the first time. The second time it wouldn't mount, DiscWarrior said the directory was very badly damaged. I tried erasing it with Apple's Disc Utility. Now, it takes a long time to appear on the desktop, when it does it appears "write protected", it won't eject because it's "in use", and the Disc Utility can't see it at all.

 

Some of the suggestions at /helpdesk/flash_support_tips.aspx are Windows specific. Are there Mac based software tricks I haven't tried?

 

Is it time to return it under warrantee?

 

Is there a way for me to tell if this is a counterfeit flash drive? (Which would save having to return it.)

 

Many thanks,

James

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...