Jump to content
Corsair Community

RMA Status- no updates


rickykemp

Recommended Posts

hello,

 

i recently sent my RAM in for an RMA as i had a faulty stick in a pair.

 

case number is 1107894

 

apparantly the parts were received on the 15th, and its now the 21st of september, and i havent had any updates on the actual status of my RMA or where in the RMA process my RAM is, i have also contacted the RMA department and have had no reply.

 

erm, help?

Link to comment
Share on other sites

ok, well, i dont really know what has gone wrong here, but my package hasnt actually been sent out yet or even picked up by UPS in over 24 hours, and is apparantly sitting in Corsair's NL hub where i sent my stuff for an RMA.

 

i've tried geting in contact with customer services, and had no reply as yet, and UPS have told me that they havent picked up the item yet.

 

can someone get in contact with me over this, as i would really rather like my RAM, and have had to wait for it already.

Link to comment
Share on other sites

  • Corsair Employees

I have sent them a message to contact you but I would give it another day before I went to crazy the system is 48-72 Hours behind what is actually happening it is not real time.

I am sorry we can no longer check RMA status in Tech Support; please call our customer service at 888-222-4346 or 510-657-8747 Ext “3” or send them an email (rmaservice@corsairmemory.com) with your RMA# and ask them for the status!
Link to comment
Share on other sites

right, well, no reply to any of my messages, and UPS have updated me to say that Corsair have not authorised them to collect the package. Corsair are entirely unreachable with the contact telephone numbers being based in the US, and myself in the UK. i am not prepared to be calling them on a premium international rate number and having to do this in either the late evening or early morning.

 

could you please provide me with the contact number for the netherlands Corsair hub, or at least tell them to actually get UPS to collect my stuff, considering that i paid for a premium service to ship my items to you guys, and you guys have used a heavily delayed saver service which you havent even dispatched yet.

 

im sorry for my tone, but i was expecting to have had my RAM back by now, and i wouldnt be so irritated if you guys were actually waiting on the parts when in fact they are sitting somewhere waiting to be givin to UPS.

Link to comment
Share on other sites

yes. i got my ram today.

 

unfortunately, i'm having problems with the two new sticks.

 

started off fine, and i was very happy. system detected all of it, then, whilst playing Bioshock, i started having BSODs. then, after a while, they got more frequent, and then they started to happen on boot every time, and then resulted in the PC refusing to complete POST.

 

using Memtest, my original 2 sticks that i did not have RMA'ed are fine, go through the test without a flaw. they are v2.1 sticks.

 

the new sticks i got through RMA which are v3.84 i believe error at numerous stages of the tests, in single sticks, and in a pair, as well as in every RAM slot on my motherboard.

 

as i said before, my original two sticks are fine, and in any configuration of slots.

 

RMA again?

 

update:

 

i have flashed the BIOS of my motherboard to the newest available, and i have also updated my P45 chipset drivers. still the same issue with BSOD on boot and errors in memtest with the RMA'ed sticks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...