Jump to content
Corsair Community

Performance issue with brand new X64 (64D1)


davide69

Recommended Posts

Hello, today I have bought two SSD X64 for setting a raid 0 configuration. I have a MSI P6N-SLI motherboard with a nVidia 650i-SLI chipset. This chipset supports 4 SATA-2 (4 ports) drives and 4 PATA drives (2 IDE ports).

All the ports are occupied (2 ide HDs, 2 IDE DVDs, 2 SSDs and 2 sata HDs).

Windows vista is at the moment installed in the 2 sata HDs.

 

Before starting configuring the raid I wanted to benchmark the disks in single configuration. I tried ATTO, HD Tune and HD Tach and with my big surprise I saw that I could not reach 170MB/s read and 100MB/write in both drives, wherein the specs should be 220MB/s read and 170MB/s write.

 

I tried several alignment (64kb, 128kb, 256kb) and several allocation size on format (4096, 32kb, 64kb) but with no success.

 

At the end I set the raid 0 up with the nVidia controller, I installed windows 7 (trial) and tested with ATTO in his default test configuration. Also in this case the max write and read speed where about 90mb/s and 140mb/s respectivelly, as if there was no raid configuration.

 

I start believe it is a controller related problem. I googled a lot and checked also the posts in the forum without finding any hint.

 

Has anyone a clue about a possible solution to the problem or about some incompatibility with the nvidia sata controller (maybe because all the ports are occupied)?

 

Thanks a lot in advance for the help and best regards,

 

Davide.

Link to comment
Share on other sites

I would go back and try and recreate the partition and when you setup the Raid use 128k Block size and then for the QUICK format use 32K allocation then bench the system again with ATTO.

 

Hello RAM GUY, thanks for the hint. Do you really mean 12kb stripe size or 128kb? I tested already the 128kb stripe size and the 32kb allocation size with no improvement. But, in any case, what makes me really dubious, is the fact that even in single drive configuration (no raid) the performance are definitelly below the theoretical specs. And I tested various option like write cache enable/disabled, advanced perofrmance enable/disabled.

 

I ordered a new sata-II controller based on silicon image chip. I hope the situation is going to improve. My suspect is that the nvidia chipset 650i simply sucks, and this is supported by the plenty of posts I've found (google) of guys disappointed with the raid performance of the nforce 650i chipset.

 

Thanks a lot and best regards, Davide.

 

PS: I will report about the performance with the new controller.

ATTO-X64.png.93c7c9a090d443539a877d5c5214bfc4.png

Link to comment
Share on other sites

  • Corsair Employees

Yes sorry about that I was in too much of a hurry it should be 128K for the Raid and 32K for the format those settings showed the best performance with any 64Gig SSD I tried when in a raid.

And can you test the drives one at a time and please make sure that you delete the raid array before you quick format it as single.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...