Jump to content
Corsair Community

Slight clicking/ mechanical noise coming from h50


J400uk

Recommended Posts

Got my H50 today and installed it in my new build PC. The temperatures are very good so I'm happy in that respect.

 

However although its reasonably quiet, there is a faint clicking/ mechanical noise coming from the H50, sounds almost like the noise a hard drive makes when accessing data. Does anyone know if this is normal? I'm finding it slightly annoying and wondering if they all do this or if this one is faulty.

 

Would be appreciative of any input

 

Cheers

Link to comment
Share on other sites

  • 2 weeks later...
I just installed mine a couple days ago as well, and mine does the same thing. A slight clicking/mechanical sound. I have to put my ear right up to the fan vents to hear it, though. I was also wondering if this is a normal thing or not. I'm guessing most people don't notice it because of their overall case noise.
Link to comment
Share on other sites

  • 2 weeks later...

I'm interested in this too as am experiencing exactly the same noise. I assume this is just the pump doing it's thing but I will try what OLK said above, later this evening.

 

One thing, when I turn mine on, I hear a scratching noise for 2 or 3 seconds, then it goes away. Only happens when the pc is turned on. Is this normal. I assume it's the pump initialising. I have the radiatior mounted with the 2 hoses coming from the top of the rad, and they are going to the bottom of the block, with the corsair logo facing upwards.

Link to comment
Share on other sites

  • 4 weeks later...

Hi, I'm very curious to know if any of you guys ever found a solution for this? I'm having exactly the same noise problem and so far I've tried turning the radiator upside down, tightening the screw etc. but no luck. Would be most grateful if anyone could help me/us out with this problem.

 

I have a ton of work to do over the next couple of weeks and being without a computer would be a big problem so I'm really hoping I won't have to go through all the hassle of filing an RMA - if at all possible. Thanks :-)

Link to comment
Share on other sites

I never found a solution, in the end just decided to live with it. Seems to have got worse over time. I have considered RMAing it, but I really can't be without my computer for weeks waiting for a replacement to ship half way round the world.
Link to comment
Share on other sites

Mine isn't making those sounds, well i cant hear them, make sure the screws are all tightened the same amount to the CPU.

 

My pump is set up so that the corsair symbol appears upright (right way up) and the Radiator is set up so the hoses come out the top, and fan is set to suck air into the case, with a exhaust fan just above the radiator.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...