Jump to content
Corsair Community

Asus P5Q (Regular) and TWIN2X2048-6400C4


Recommended Posts

I own an Asus P5Q motherboard (Regular) and a set of corsair TWIN2X2048-6400C4.


I purchased this memory for use in a new system build for a customer back on 9/12/2007 and found that it was incompatible with the motherboard and after a lengthy RMA process of various things trying to determine my problem (System passed memtestx86 without error, installed windows vista fine, but downloaded files and installed programs like games would have file corruption so I replaced motherboard and hard drive first) it was beyond the refund date and my only choice was to do an RMA exchange for the ram on 11/15/2007. I opted to exchange the ram for less-expensive more-compatible ram from another manufacturer at my expense.


Anyway, since I had effectively lost money on this build, and I was stuck with a new pair (from RMA) of memory I decided to use it in my new build for myself. I've been driving myself nuts trying to determine the source of my problem.


Firstly, I cannot run this ram at its advertised voltage and latency (2.1v and 4-4-4-12) and play a game and have it be stable. Usually I get a BSOD followed by a system reboot. According to your site, the memory should be compatible at these settings. I am running the latest bios and drivers for my motherboard. Windows XP Professional, 32bit, SP3 Installed. I will say that I've been fighting on and off with this since October 2008 or so in this configuration (periodically testing at these settings following bios updates only to be dissapointed). The sick thing is that the system posts, runs memtestx86 without errors for multiple passes yet as soon as I load up a game and play for a bit, bam reboot.


I instead usually opted to run this memory at the slower but more stable 5-5-5-18 at 1.8v. Of course memtestx86 passes here without error also. (I have only ever seen one instance of a memtestx86 failure and that is when my video card's display had corrupted and I was getting artifacts on even my bios screen. After replacing the card I haven't had an error detected) I still experience random game crashes (Fallout 3) and the far more scary "The memory could not be read" or "File could not be read" in a random MPQ while playing world of warcraft (and requiring me to run repair.exe or use a backup). My hard drives all check out fine (tried both drives) which is really weird.


I am considering upgrading to a SATA hard drive which may help with file errors but I'm not sure, also I just ordered a Corsair 750W psu which I should have Wednesday on the off-chance that this is a power issue. (I read that rosewill power supplies have overloaded 5v rails and are just re-branded coolmax psu's) I'm also interested in upgrading my memory outright along with the hard drive when windows 7 comes out and go with the 64bit edition.


My question is this. Is there anyway I can have this memory run stable on my system at advertised settings (Kind of a waste not to since this ram was over $100 when I bought it and its only running at speeds that $60 ram at the time could do). Or should I just pick up some more-standard ram that runs at 5-5-5-15 at 1.8v (probably a 4gb kit or possibly 8gb)?


I am kind of tempted to buy Q2X8G6400C4DHX or TWIN2X4096-6400C4DHX but with my bad experience with this ram running at 2.1v I'm not sure. Also I have repeatedly read that in order to use 4 sticks of memory you usually have to underclock it which seems to be even more of a waste when you could just buy cheap ram and run at that speed. I'm also tempted to just go with another manufacturer for this upgrade and use vanilla ddr800 since I've had better luck with it with other "Buggy" Intel boards.

Link to comment
Share on other sites

I've got quite a similar setup to yours P5Q Pro Turbo and TWIN2X4096-6400C5C and I'm RMA'ing the motherboard as it appears to be the problem.


What I'm worried about though is the sheer number of posts on the front page of this forum relating to the various verisons of the Asus P5Q. It's either an extremely popular motherboard or it just doesn't like Corsair RAM... I'm hoping it's the former.

Link to comment
Share on other sites

I've been a big fan of Asus for awhile now. The crazy thing here is that memtestx86 has no reported issues in any configuration. I'll try the upgraded PSU and report back, I have read in other forums that the chipset on this board is a bit flakey, even after multiple bios updates.


I've had issues with budget asus boards but this thing cost me quite a bit for a non-sli board so I wasn't anticipating any problems. I actually opted to use this board as a replacement to an Intel branded board that I RMA refunded due to issues I had with the ACPI Drivers.


Well, in any case if I can't get this thing fired up using the advertised settings I'll have to switch to some vanilla ram. I doubt the motherboard has a physical defect as it works 90% of the time with this ram at SPD settings, and under normal operation (non-gaming) at jdec settings and voltage. Which is why I'm mulling over whether it may be a power issue or not.


I'd personally be more apt to blame the chipset than Asus or Corsair. Though the board does come with a 3 year warranty so if it is an issue I guess I could contact them about the issue.

Link to comment
Share on other sites

I installed my new power supply and once again set my memory to 4-4-4-12 @ 2.1v.


I haven't increased my NB voltage by .1 volts yet. I was able to play fallout 3 for about an hour without any problems. The issue seemed to be rather random, so I'll play it by ear.


I ran both sticks with memtest.org v2.11 for 8 passes with no error.


I also ran each stick individually for 4 passes with no errors.


I then ran the memory with their orders reversed for 12 passes with no errors.


I'm not sure this is conclusive as I have run these tests before and not received any errors even with the old power supply. The weird thing was that the computer would reboot usually while playing a game so I'm thinking it was power-related possibly.

Link to comment
Share on other sites

Not sure if it matters, but the box for the ram has a "G" at the end.


TWIN2X2048-6400C4 G






Yeah all that means is that its ROHS compliant.


Well, in any case, after a few gaming sessions so far it would appear that the power supply was in fact my issue. It was a 550W psu to begin with, but I did a little reading and that rating may have been inflated. Kind of a surprise to me since so far Rosewill power supplies have been decent enough, but I guess it wasn't in this case.

Link to comment
Share on other sites

Well, I spoke too soon.


I was playing and I had another blue screen/reboot.


Following your advice I upped my NB voltage from 1.10V to 1.20V. I'll try that and see how it goes. It did seem to me that I was able to play longer than I was able to previously with the old PSU but maybe I was just lucky. If all else fails I can go back to 5-5-5-18, at least it never rebooted (though I did get crashes and 'memory could not be "read"' issues). I may have to get that vanilla ram afterall.


I'm currently running yet another memtest....though considering I haven't found any issues thusfar, I doubt that it will detect any issues this time.

Link to comment
Share on other sites

Well, I guess my system can't handle this memory. I have no choice but to run it at 5-5-5-18 at 1.8v it seems. Random bluescreens/reboots isn't fun. I'm planning on upgrading to 4GB of ram when windows 7 comes out, so I'll have to keep that in mind.


I doubt the ram could be bad... and the system runs fine unless I'm running it at spec, so I don't know.

Link to comment
Share on other sites

Everything was set to Auto except the change to the voltage that you recommended.


Also I only had 2 modules installed, the 2 for the kit.


Always the ram was installed in dual channels. I have not attempted to do this with both installed in single channel simultaneously. I've tried rotating the banks as well and no luck, though per my manual's recommendation I generally have them in the first slots of the channel as supposedly its better for overclocking.


I have not managed to get any Memtestx86 failures at all and if it weren't for the bluescreens I'd have no proof of having a problem at all.


Sorry for the lateness of my reply. I just started playing wow again and I neglected to check this post.


I don't know what "auto" defaults to so I'll have to look into that.


I've been running without an issue for the past week or so at 5-5-5-18@1.8v.

Link to comment
Share on other sites

Alright. I sat at my PC with a notepad and wrote down everything I could find. It may not be 100% accurate but I hope I have it correct.


This is all taken from the "Ai Tweaker" section of my Bios.


Ai Overclock Tuner [Auto]

-If set to manual (just to check numbers) FSB Frequency is set to 333 and PCIE Frequency is set to 100.

CPU Ratio Setting [Auto]

FSB Strap to North Bridge [Auto]

Dram Frequency [DDR2-800mhz]

Dram Timing Control [Manual]

1st Information: 4-4-4-12-3-42-6-3

CAS# Latency [4 Dram Clocks]

Dram Ras# to Cas# Delay [4 Dram Clocks]

Dram Ras# Precharge [4 Dram Clocks]

Dram Ras# Activate to Precha [18 Dram Clocks]

Ras# to Ras # Delay [Auto]

Row Refresh Cycle Time [Auto]

Write Recovery Time [Auto]

Read to Precharge Time [Auto]

2nd Information 8-3-5-4-6-4-7

READ to WRITE Delay (S/D) [Auto]

Write to Read Delay (S) [Auto]

Write to Read Delay (D) [Auto]

Read to Read Delay (S) [Auto]

Read to Read Delay (D) [Auto]

Write to Write (S) [Auto]

Write to Write (D) [Auto]

3rd Information 13-5-1-4-4

Write to Pre Delay [Auto]

Read to Pre Delay [Auto]

Pre to Pre Delay [Auto]

All Pre to Act Delay [Auto]

All Pre to Ref Delay [Auto]

Dram Static Read Control [Auto]

Dram Read Training [Auto]

Mem O.C. Charger [Enabled]

Ai Clock Twister [Auto]

Ai Transaction Booster [Auto]

<In gray below>

C/P: A1 A2 A3 A4 A5 | B1 B2 B3 B4 B5

LVL: 10 10 10 10 10 10 10 10 10 10

CPU Voltage [Auto]

CPU GTL Reference [Auto]

CPU PLL Voltage [Auto]

FSB termination Voltage [Auto]

Dram Voltage [2.10]

NB Voltage [Auto]

SB Voltage [Auto]

PCIE Sata [Auto]

Load Line Calibration [Auto]

CPU Spread Spectrum [Auto]

PCI Spread Spectrum [Auto]

CPU Clock Skew [Auto]

NB Clock Skew [Auto]

CPU Margin Enhancement [Optimized]


Under Advanced settings:

CPU Configuration

Manufacturer: Intel

Brand String: Intel ® Core 2 Dual CPU E8500 @3.16GHZ

Frequency: 3.16 GHZ

FSB Speed: 1333MHZ

Cache L1 64KB

Cache L2 6144KB

Ratio Status: Unlocked (Min:06 Max 09.5)

Ratio Actual Value: 9.5

CPUID 10676

CPU Ratio Setting: Auto

L1E Support: Enable

Max CPU ID Value Limit: Disabled

Intel ® Virtualization Tech: Enabled

CPU TM Function: Enabled

Intel ® SpeedStep Tech: Enabled

Intel ® C-State Tech: Disabled

Link to comment
Share on other sites

That's the thing, I already ran them individually. I ran them for 4 passes when it was suggested the first time. How many passes should I run them for? How long does it take to make an intermittent error occur?


I put my system at those settings today (dual channel, 4-4-4-12@2.1v) and played wow for a couple hours then suddenly it bluescreened yet again. Its really nuts. I even did a Bios settings reset to default values which changed

Mem O.C. Charger [Enabled] to [Auto]


Should I just RMA the ram?


How many passes should I run the ram at individually if 4 wasn't enough?

Link to comment
Share on other sites

This is the stop code that I saw, hopefully I wrote it down right.


Stop: 0x0000008E (0xC0000005, 0x805F0BE5, 0xB764E9FC, 0x00000000)


Again, I stress that this only happens when I overclock the ram (IE Run it at advertised voltage and timings).


This is what technet was able to glean:


"One or more of the random access memory (RAM) modules that are installed on your computer are faulty."




Which is what I suspect. Its extremely hard to reproduce. I have not been able to see anything pop up on memtestx86, but apparently under a certain load that memtest doesn't test for it causes a failure.


A few weeks back my video card failed. During the failure my video was corrupted, including the bios and memtestx86+ screen. I ran memtestx86+ during this failure and I DID get 2 failures on 2 tests. I have not been able to reproduce this error since then. I'm thinking that there must be some kind of issue that is happening that either memtestx86+ doesn't test for or is having difficulty creating a failing condition.


Given that I have no problem running the ram at 5-5-5-18 at 1.8v, if you don't think I should RMA the ram I'll probably replace them with more-stable, non-overclocked memory. I don't think that I have a bad motherboard here.

Link to comment
Share on other sites

  • 1 month later...

I received my RMA'd ram back about 2 weeks ago, unfortunately I had a problem with one of the modules I received. One module works perfectly the other module would not post in my pc. I tested the good module in all 4 banks and it works perfectly while the second module does not work at all. I even placed the bad module into another PC (A HP system) and it wouldn't post either (well actually it did post once but the screen was garbled as it uses shared memory for the video card).


I contacted customer service about this issue and they agreed to send me an advanced RMA and to have the modules tested by a tech at the listed speed and voltage prior to shipping. Unfortunately, I have yet to receive a tracking number or said advanced RMA. Its been about a month since I made the initial RMA and 2 weeks now waiting for the advanced RMA. I contacted them last week and they said they would put priority on it however I still haven't received any word. Running my system with only 1gb of ram is very frustrating and my games are borderline unplayable.




I JUST received my package via UPS at 5:00pm today. I'll install and hopefully this will take care of my problem. Thanks for your support.

Link to comment
Share on other sites

Well I'm running out of ideas.


Both of these new modules I just received post in dual channel mode.


I set them to 800mhz, 2.10v and 4-4-4-12 in dual channel mode (banks 0 and 2 yellow sockets).


Fired it up and in test 6 there was one error. Now these were tested by a technician before they were shipped so its probably unlikely to be a ram problem at this point.


Then I set everything to default at 800mhz, 1.80v, and 5-5-5-18 and in test one the screen was filled with errors (lots of red), and again when I swapped the modules in dual channel mode.


I am right now in the process of testing the modules individually at 4-4-4-12 at 2.10v to see if I can get them to fail individually in either bank.


I may have a bad motherboard afterall. I've read multiple people having issues with my board with various brands of memory, so i may have to take that as a loss. The thing that puzzles me the most is that with my other modules I never got an issue with memtestx86+ 2.11 at all.

Link to comment
Share on other sites

Ran the first module in banks 0 and 2 for one pass with 0 errors


Ran the second module in banks 0 and 2 for one pass, both failing on test #7 [Random Number Sequence].


Since I still have the working module from my past failing RMA, I am using it along with this working module. I am now running both at 800mhz at 4-4-4-12 at 2.10v.


Oddly memtest reports them to be running at 400mhz (DDR801) and the FSB at 334mhz instead of 333mhz. I'm not sure if that's anything to worry about though. As I stated everything but the ram settings are set to automatic. (I think cpu-z reports them running at 400.5mhz at 2.10v).


Right now so far... so good. I've let it run for 2 full passes with 0 failures in dual channel mode. I'm going to let it run for the rest of the evening. They aren't matched pairs afterall. But I'll take working memory over non-working memory anyday.


I may take this as good news because I just ordered 4GB of DDR800 ram (standard stuff that runs at 1.8v and 5-5-5-18 in case it was a compatibility issue wiht my board and I was growing impatient, along with a 1TB Sata HDD and Windows 7) and if I had to get a new motherboard I might as well have just gone with DDR3 and a new CPU.


Thanks again for your support. If all works out this should be my last post about this build.


I'll contact customer service regarding returning the failed modules.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...