Jump to content
Corsair Community

Disfunctional Flash Voyager 16 GB :(


Recommended Posts



I've had this Corsair Flash Voyager 16 GB drive for a couple of months and in the last two to three months, odd things have been happening and building up to this point.

First, sometimes when I insert the flash drive, it doesn't recognize it as Flash Voyager. It recognized it as USB2Best something, I forgot the full name. Basically, I click on the F: (my removable drive) and it doesn't work. At other points, when I plug it in, it shows the name I gave it and it works fine. I don't know what's going on. I tried this on at least 4 computers and it persists.


In case it's of importance, I have Windows XP Pro SP3. The other computers I tried it on varied from Windows XP Home SP2, SP3, and Vista.


Now, more recently, I tried my flash drive and it doesn't even recognize it as the weird name (USB2 something). It doesn't work at all. I tried the extension given to me by Corsair, the usb cable, and I plugged it in all the way, and the name I gave it came up. I opened it and all the files are either deleted or show up with the name "V" and are ALL 5,505 kb. What on earth is going on?


I'm glad I backed up some of my files to the computer a while ago, I was worried something might happen. I lost a few files with this problem, but that's not my worry. I just need a flash drive to work since classes begin soon.


What do I need to do to replace this?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...