Jump to content
Corsair Community

Disappointed - Brand New Voyager 64 GB has problems


dstoltz

Recommended Posts

Hi Folks,

 

I am using my new voyager 64 gig on 2 machines - Vista 32bit, and an XP Pro 32bit...

 

I plugged it into Vista, it "Saw" it as drive M, and I started copying files to it. All the files on the drive ended up looking like hyroglyphics - so I tried to format it. In Vista, it would not allow me to format it through Explorer. So I took the drive to work.

 

Now on my XP Pro machine, same thing - it won't let me format through explorer - so I started reading the threads here....I tried the CMD box format too - if I try to format it with FAT32, it says the volume is too big for FAT32.

 

If I try to format it (with CMD prompt) with NTFS as the file system, it says it's not supported on this device optimized for removal. So I went into properties of the device and changed it to optimize for performance.

 

Now when I try to format it with cmd prompt in NTFS format it says the device is write protected!

 

What the heck is going on here? I've never had such problems with a flash drive before - and reading the threads on this forum leave me a bit worried.

 

I've also tried the SDFormatter suggested by support in another thread. That tool doesn't allow me to select a drive (the drive dropdown is disabled in the tool)...

 

Any help for a really frustrated user?

 

Thanks!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...