Jump to content
Corsair Community

P128 performance issue


felonyOne

Recommended Posts

I installed the P128 in my machine several weeks ago and as time goes on the performance seems to get worse compared to my Raptors.

 

I'm not so much worried about the R/W speeds as I have not run any benchmarks to test that. What does bother me is this stuttering/pause issue.

 

For example, when playing World of Warcraft if I hover over an item to see it's tooltip, the system will stutter/pause. The system will also stutter/pause when I activate an addon that directly accesses files on the HD such as the combat log.

 

I'm not really sure what's causing this or why. When I purchased the P128 I read that stuttering wouldn't be an issue. However, it clearly is and seems to be getting worse.

 

Could someone please give me some advice as to what I can do to cure the stuttering problem. I read the FAQ, I saw that you shouldn't do a Full Format on the SSD, (I've only ever done Quick), I saw that I should keep at least 15% of space free on the disk.

 

My system is fairly old, Core2Duo 2.4GHz, 680i Mobo, 4GB DDR2, but I can't believe it's the other components that are compounding this stuttering issue with the drive.

 

Please help!!! I don't want to have to go back to using my Raptor drives after shelling out 300 bucks for this SSD.

 

edit: Running Vista32

Link to comment
Share on other sites

well I got it from newegg, at whatever price they had it at

 

i just said 300 bucks to give a roundabout number

 

I've had it installed and have been working on this system for over a month now. At first everything was running very smoothly. Now however after a month, the stuttering/pause issues have become very noticeable.

 

At first I thought it was a heat issue since I still have my 2 Raptors in there in a raid config. However, I moved the P128 to its own space in my case with a fan literally blowing over it but the stuttering still occurs.

Link to comment
Share on other sites

Felonyone, let me know where you found the 128 for $300.00. The egg lists them at $345.00. If I can save I will. I don't stress over a few dollars but $45.00 I will.

 

Corsair had a $40.00 rebate offer for newegg customers who bought the P128. It ran from 07-14-2009 to 07-20-2009. That brought the drive to $285.00 and they even threw in free shipping. You might want to keep your eyes peeled for another round of those deals.

 

Corsair does a great job of offering rebates and always honors them..

Link to comment
Share on other sites

I installed the P128 in my machine several weeks ago and as time goes on the performance seems to get worse compared to my Raptors.

 

I'm not so much worried about the R/W speeds as I have not run any benchmarks to test that. What does bother me is this stuttering/pause issue.

 

For example, when playing World of Warcraft if I hover over an item to see it's tooltip, the system will stutter/pause. The system will also stutter/pause when I activate an addon that directly accesses files on the HD such as the combat log.

 

I'm not really sure what's causing this or why. When I purchased the P128 I read that stuttering wouldn't be an issue. However, it clearly is and seems to be getting worse.

 

Could someone please give me some advice as to what I can do to cure the stuttering problem. I read the FAQ, I saw that you shouldn't do a Full Format on the SSD, (I've only ever done Quick), I saw that I should keep at least 15% of space free on the disk.

 

My system is fairly old, Core2Duo 2.4GHz, 680i Mobo, 4GB DDR2, but I can't believe it's the other components that are compounding this stuttering issue with the drive.

 

Please help!!! I don't want to have to go back to using my Raptor drives after shelling out 300 bucks for this SSD.

 

edit: Running Vista32

 

Ah, thought i was the only one having this problem. This has been bugging me alot these last days.. Im getting the exact same IO-lag, halt/freezes and random second, lasts for a sec or 2 as the quoted writer..

The symptom is random micro IO freezes regardless of which drive im reading/writing from/on. I see it in windows, games and so on...

Even as im writing this text, ive had it 5 times in 5 lines.. In vista and windows 7 without the ssd disk, everything is fine...

It seems that the system is waiting for a response to a poll against the ssd..

Cant see anything in the system logs, or performance logs.. or on the cpu meters..

Anyone have any idea why ?

 

PS! I idnt have these issues at the start when the drive was unused.. but now...

PS2! I did a quick format, clean install windows 7 RTM, bought the drive at komplett.no

dragmore

Link to comment
Share on other sites

i had my p128 installed on windows 7 RC for about 3 weeks.

 

Recently, i deleted all the partitions7 R and installed Windows 7 RTM.

 

I noticed that my Windows Experience Index Hard Drive score dropped had dropped from 7 to 5.9.

 

The system still feels blazing fast, and installs are going smoothly, but I am worried about Windows reporting such a low score now. How/When does this auto-healing take place? I have the 'old' firmware as well.

Link to comment
Share on other sites

I get the same 5.9 WEI score, when I use a single P128SSD, and only a 6.4 when I use 2 of them in a RAID 0 or even 3 of them in a RAID 0.

 

I look at the WEI as a very general guideline, at best, and a hardware marketing tool at worst.

Link to comment
Share on other sites

Fair enough, heres 3 pictures of a ATTO run:

 

1: Fresh install:

 

2: Today (40% full)

 

3. 3 weeks ago, (95% full)

 

And it clearly is deterioating. But as mentioned eariler in this thread, my main problem is the random freezes.. Is this a dead product that needs to get replaced?

 

br

TE

atto_result_fresh.thumb.png.3833f53e9c6d5aba7fe7635c0dc007fb.png

atto_full.thumb.png.263c624482de807077a81fce6b4903f7.png

atto_aug.jpg.6d203188bdada3a55ff69304f7bdb7fd.jpg

Link to comment
Share on other sites

  • Corsair Employees
They will slow down as you fill up the drive that is normal and even a HDD will do the same. Please tell me exactly what you are doing when this occurs and anything that is running in the back ground. But from the bench mark the drive appears to be running properly. Also is this the only HDD in the system, or do you have more than one and how are they configured?
Link to comment
Share on other sites

Fair enough, heres 3 pictures of a ATTO run:

 

1: Fresh install:

 

2: Today (40% full)

 

3. 3 weeks ago, (95% full)

 

And it clearly is deterioating. But as mentioned eariler in this thread, my main problem is the random freezes.. Is this a dead product that needs to get replaced?

 

br

TE

 

Here's mine a week after installation of W7

 

http://img443.imageshack.us/img443/5077/atto.jpg

 

http://img176.imageshack.us/img176/8141/hdtuneread.jpg

 

Looks like my write speed is much better than my read speed compared to yours:[pouts:

 

Its weird though cause in Crystal Disk Mark i'm getting a much better read performance.

 

http://img269.imageshack.us/img269/8566/cdmy.jpg

Link to comment
Share on other sites

They will slow down as you fill up the drive that is normal and even a HDD will do the same. Please tell me exactly what you are doing when this occurs and anything that is running in the back ground. But from the bench mark the drive appears to be running properly. Also is this the only HDD in the system, or do you have more than one and how are they configured?

 

Hi. I dont completely agree on a HDD gets slower when its full. That depends on where on the plate data is located, filesystem type and so on..

 

But as u can see on my logs, the drive was actually faster when it was 95% full than yesterday days log at 40%.. So in my view its getting worse steadily...

I just hope that when the "trim" app comes out or FW, that the speed will pick up again..

 

Regarding the IO freezes:

 

1. My IO setup is as following : SSD as main disk for OS, a raid5 with 4x750gb on the ich10 controller in RAID mode (ssd on same controller)

2. Got the newest 8.9 Intel matrix drivers

3. IO freezes happen at random, but is worse when theres alot of WRITES to the SSD.

4. I have vista64 on a sparedrive i can swap with the SSD, here the system is rock solid with everything else as the same as the windows 7 SSD system..

 

So its either the SSD disk or windows 7 RTM install thats the issue here..

Link to comment
Share on other sites

Your own test show a phenomenal write speed...so how is the freezing happening during the SSD's writing? Maybe its waiting for the other device(s) to catch up with their output.

 

Yes... HDDs get slower as they get full... all of them, and have always been that way since the MFM/RLL days. Put the data on there any way you want, its still going to be slower, as it fills.

 

I didn't like the performance from my Intel ICH10R controller. I switched to an Adaptec and haven't looked back.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...